Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002396 [JEDI VCL] 00 JVCL Components major always 2004-12-17 16:11 2004-12-29 16:48
Reporter anonymous View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002396: Unable to run install
Description I downloaded the latest JVCL from the daily zips (complete set) and I am trying to install JVCL for Delphi 2005;
When executing the install.bat everything works fine until I am asked for the JCL directory - however the installer keeps telling me that it can't find JCL 1.92 or JCL 1.93 (CVS). The directory structure is maintained as in the zip-file. What am I doing wrong?
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005910)
user72
2004-12-18 03:06

Did you run the JCL installer before running the JVCL installer?
(0005911)
anonymous (viewer)
2004-12-18 03:11

I am getting confused; what is the difference between JCL and JVCL?
In the downlaod section, I can only find JVCL file ....
(0005917)
AHUser (developer)
2004-12-18 06:51

JCL is a differnet JEDI Project. The JVCL requires the JCL, but the JVCL is _not_ the JCL.

An example:
The JCL is something like the RTL.
The JVCL is something like the VCL.
You cannot install the VCL without installing the RTL before.
And so you cannot install the JVCL without installing the JCL before.

http://jcl.sf.net/daily [^]
(0005921)
anonymous (viewer)
2004-12-18 10:50

Got it. Thank you.
Now I am able to install JCL + JVCL with Delphi 7 - however, with Delphi 2005, JCL will not install; the Install.bat ends with an error and deletes the installer.exe.
(0005924)
AHUser (developer)
2004-12-18 15:45

The JVCL and the JCL do not work with Delphi 2005 Trial because the installers require the dcc32.exe
(0005931)
anonymous (viewer)
2004-12-19 08:35
edited on: 2004-12-19 08:36

It's not a Tial version.
Meanwhile, I installed the JCL by compiling the JCL projects from within Delphi.
Thereafter the JVCL installer runs well. But I am not sure what I missed from the automatic installation of JCL. Is there any more to adjust manually except for the paths?

(0005932)
user72
2004-12-19 12:03

> Is there any more to adjust manually except for the paths?
No
(0005971)
obones (administrator)
2004-12-21 03:34

Please try again with the very latest JCL, it should work just fine with Delphi 2005

- Issue History
Date Modified Username Field Change
2004-12-17 16:11 anonymous New Issue
2004-12-18 03:06 user72 Note Added: 0005910
2004-12-18 03:11 anonymous Note Added: 0005911
2004-12-18 06:51 AHUser Note Added: 0005917
2004-12-18 06:56 AHUser Status new => feedback
2004-12-18 10:50 anonymous Note Added: 0005921
2004-12-18 15:45 AHUser Status feedback => resolved
2004-12-18 15:45 AHUser Resolution open => fixed
2004-12-18 15:45 AHUser Assigned To => AHUser
2004-12-18 15:45 AHUser Note Added: 0005924
2004-12-18 15:45 AHUser Assigned To AHUser =>
2004-12-19 08:35 anonymous Status resolved => feedback
2004-12-19 08:35 anonymous Resolution fixed => reopened
2004-12-19 08:35 anonymous Note Added: 0005931
2004-12-19 08:36 anonymous Note Edited: 0005931
2004-12-19 12:03 user72 Note Added: 0005932
2004-12-21 03:34 obones Note Added: 0005971
2004-12-29 16:48 AHUser Status feedback => resolved
2004-12-29 16:48 AHUser Resolution reopened => fixed
2004-12-29 16:48 AHUser Assigned To => AHUser
2004-12-29 16:48 AHUser Assigned To AHUser =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker