Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002405 [JEDI VCL] 00 JVCL Components major always 2004-12-20 00:16 2005-02-04 04:08
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002405: TJvCheckTreeView Checked property not reading right array value?
Description Using the CheckTVDemo example (D6 Enterprise, JVCL3 2004-11-22) I seem to see a problem with accessing the Checked property. It does not appear to consistently return whether the checkbox is checked or not.

Changing the demo to use the Style JVCL implementation made the program work as expected. The MS implementation style appears to not work correctly (e.g. the Checked status is inconsistent).
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0005967)
user72
2004-12-21 01:34

change the followng method:

function TJvCheckTreeView.GetChecked(Node: TTreeNode): Boolean;
begin
  with CheckBoxOptions do
    if Style = cbsJVCL then
      Result := (Node <> nil) and (Node.StateIndex in [RadioCheckedIndex, CheckBoxCheckedIndex])
    else
      Result := inherited Checked[Node];
end;
(0006120)
anonymous (viewer)
2005-01-10 21:15

That looks like it. Thank you!

- Issue History
Date Modified Username Field Change
2004-12-20 00:16 anonymous New Issue
2004-12-21 01:34 user72 Note Added: 0005967
2004-12-21 01:34 user72 Status new => feedback
2005-01-10 21:15 anonymous Note Added: 0006120
2005-02-04 04:08 obones Status feedback => resolved
2005-02-04 04:08 obones Fixed in Version => 3.00
2005-02-04 04:08 obones Resolution open => fixed
2005-02-04 04:08 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker