Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002411 [JEDI VCL] 00 JVCL Components crash always 2004-12-21 02:40 2005-02-25 05:09
Reporter Rosenberg View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002411: Docking-Crash: Refered to Issue-ID 2409
Description The decribed behaviour in Issue-ID 2409 can be reproduced also in the example supported by JEDI-Project:
...\Jedi_300\jvcl\examples\JvDocking\AdvanceDemo\Delphi_Source\AdvancePro.dpr
- Run Demo
- Create for Example two new Delphi-Styled Forms
- Change for both forms their state to "Each other dockable": see in zipped attachment: Bug_Docking0.jpg
- Dock one of them to the middle of the other one: Now there is a new form created containing both forms separated with tabs: see in zipped attachment: Bug_Docking1jpg
- Effect: the new form can not be moved and the appl. crashes if you close the form and try to restore it by "Show Window"-Menuoption!
Additional Information
Tags No tags attached.
Attached Files zip file icon Bug_Dock.zip [^] (21,665 bytes) 2004-12-21 02:40

- Relationships
duplicate of 0001807closedremkobonte JvDocking: docking free floating dock clients to each other disables moving the forms 
related to 0002409resolvedobones Using Dock-Server/Client: Crash after closing Tap-Form 
has duplicate 0002704resolvedremkobonte Error moving docking windows 

-  Notes
(0005978)
remkobonte (developer)
2004-12-21 18:24

I can not reproduce the bug with the latest source.

What version of JVCL are you using?

Look in the JvDockControlForm.pas file; just above the "unit JvDockControlForm;" line there should be a line starting with

// $Id: JvDockControlForm.pas

Copy and paste that line here.
(0006121)
Rosenberg (reporter)
2005-01-11 08:20

Fileversion is:
// $Id: JvDockControlForm.pas,v 1.47 2004/09/01 15:06:37 ahuser Exp $
(0006122)
Rosenberg (reporter)
2005-01-11 08:48

Reminder sent to: Rosenberg

TO: remkobonte
please have a look to my new note
(0006125)
remkobonte (developer)
2005-01-11 15:05

JvDockControlForm.pas version 1.47 is the Beta 2 version.

Some issues are fixed in version 1.48 and up (current version is 1.55).

You might want to download the RC 1 version

http://sourceforge.net/project/showfiles.php?group_id=45786 [^]

For version history see: http://cvs.sourceforge.net/viewcvs.py/jvcl/dev/JVCL3/run/JvDockControlForm.pas [^]
(0006395)
obones (administrator)
2005-02-04 04:07

Please provide feedback on how it works with the latest version.
Should we not receive an update in the next 7 days, we will consider this issue resolved
(0006569)
obones (administrator)
2005-02-25 05:09

No answers in a timely manner -> Resolved

- Issue History
Date Modified Username Field Change
2004-12-21 02:40 Rosenberg New Issue
2004-12-21 02:40 Rosenberg File Added: Bug_Dock.zip
2004-12-21 18:18 remkobonte Relationship added related to 0002409
2004-12-21 18:24 remkobonte Note Added: 0005978
2004-12-21 18:24 remkobonte Status new => feedback
2004-12-21 18:30 remkobonte Relationship added duplicate of 0001807
2005-01-11 08:20 Rosenberg Note Added: 0006121
2005-01-11 08:48 Rosenberg Note Added: 0006122
2005-01-11 15:05 remkobonte Note Added: 0006125
2005-02-04 04:07 obones Note Added: 0006395
2005-02-25 05:09 obones Status feedback => resolved
2005-02-25 05:09 obones Fixed in Version => 3.00
2005-02-25 05:09 obones Resolution open => fixed
2005-02-25 05:09 obones Assigned To => obones
2005-02-25 05:09 obones Note Added: 0006569
2005-03-07 13:03 remkobonte Relationship added has duplicate 0002704


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker