Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002426 [JEDI VCL] 00 JVCL Components major always 2004-12-22 12:57 2005-01-02 05:14
Reporter anonymous View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002426: MessageDlgEx with delphi 2005
Description sorry for my english

the function MessageDlgEx with parameters (dckScreen, dckActiveForm, dckMainForm) doesn't work with delphi 2005.

the message is on the left upper corner of the screen (0,0)

version tested (3.00b2 and the version date 2004/12/22

Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0002398resolved Problem with TJvDatePickerEdit with Delphi 2005 

-  Notes
(0005990)
user72
2004-12-22 14:03

Probably the same issue. I expect there to be more of these...
(0006000)
remkobonte (developer)
2004-12-23 12:00

We have D2005 at work now, so I could check this out.

You must set either Position to poDesigned or PopupMode to pmAuto.

The value of Position is set to poDefaultPosOnly in CreateNew. If PopupMode = pmNone (the default) then the window will be recreated in TCustomForm.ShowModal (RecreateWnd call), because Position is posDefaultPosOnly the position is not stored while the window is recreated. Thus

* either set position to poDesigned, so the position is stored while the window is recreated.
* or set PopupMode to pmAuto, so the window is not recreated in the ShowModal call.
(0006005)
anonymous (viewer)
2004-12-24 09:06

thanks but i have my form = poScreenCenter and PopupMode = pmAuto and doesn't work
(0006006)
remkobonte (developer)
2004-12-24 12:53
edited on: 2004-12-24 12:55

I meant that the properties of the form created by MessageDlgEx must be changed. Thus change in the CreateDSAMessageForm function in JvDSADialogs.pas:

  Result := TDSAMessageForm.CreateNew(Screen.ActiveCustomForm);
  try
    with Result do
    begin
      {$IFDEF VCL}

to

  Result := TDSAMessageForm.CreateNew(Screen.ActiveCustomForm);
  try
    with Result do
    begin
      Position := poDesigned;
      PopupMode := pmAuto;
      {$IFDEF VCL}

(0006007)
anonymous (viewer)
2004-12-25 02:37

Thanks, it's good. i just add {$IFDEF DELPHI9}

  Result := TDSAMessageForm.CreateNew(Screen.ActiveCustomForm);
  try
    with Result do
    begin
      {$IFDEF DELPHI9}
    Position := poDesigned;
    PopupMode := pmAuto;
      {$ENDIF DELPHI9}
      {$IFDEF VCL}
(0006053)
obones (administrator)
2005-01-02 05:14

This is now fixed in CVS

- Issue History
Date Modified Username Field Change
2004-12-22 12:57 anonymous New Issue
2004-12-22 14:02 user72 Relationship added related to 0002398
2004-12-22 14:03 user72 Note Added: 0005990
2004-12-22 14:03 user72 Status new => feedback
2004-12-23 12:00 remkobonte Note Added: 0006000
2004-12-24 09:06 anonymous Note Added: 0006005
2004-12-24 12:53 remkobonte Note Added: 0006006
2004-12-24 12:55 remkobonte Note Edited: 0006006
2004-12-25 02:37 anonymous Note Added: 0006007
2005-01-02 05:14 obones Status feedback => resolved
2005-01-02 05:14 obones Resolution open => fixed
2005-01-02 05:14 obones Assigned To => obones
2005-01-02 05:14 obones Note Added: 0006053
2005-01-02 05:14 obones Assigned To obones =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker