Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002440 [JEDI VCL] 00 JVCL Components major always 2004-12-27 05:09 2005-01-03 05:07
Reporter boerema1 View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002440: Error loading JvMMD6D when starting Delphi
Description I get either an external exception 80000003 or een access violation (read of address ...) when starting Delphi when it is loading JvMMD6D. I have D6 personal on Window ME.
Both JCL and JVCL are of today from CVS and I renamed the old directories. No old dcu's or bpl's are in the way.
It seems to be something in one of the JvFullColor files because when removing them form JvMMD6D/R Delphi loads without problems.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006028)
boerema1 (reporter)
2004-12-29 03:08

After adding JvFullColorSpaces to the uses list of my program I also get the access violation at startup. After the second access violation Delphi stops in JvFullColorSpaces.PrettyNameStrings at the line AHookColorBox.PopulateList just after CreateWnd.

Call stack:
PrettyNameStrings
ColorToPrettyName line 442:
  AIndex := PrettyNameStrings.IndexOfObject(TObject(Value));
TJvDEFColorSpace.GetColorValuesCallBack line 1509:
  AddCustomColor(AColor,Copy(S,3,Length(S)-2),ColorToPrettyName(AColor));
TJvDEFColorSpace.Create line 1495:
  AddDelphiColor(clNone);
JvFullColorSpaces initialization line 1750:
  ColorSpaceManager.RegisterColorSpace(TJvDEFColorSpace.Create(csDEF));
(0006059)
anonymous (viewer)
2005-01-02 09:10

I cannot reproduce this error on my computer.
However, I changed the way to get pretty name strings. It now uses the jvcl constants.
Sorry for the convenience.
Florent
(0006063)
boerema1 (reporter)
2005-01-03 03:09

Thanks. With the newest version everything works fine as far as I can see.

- Issue History
Date Modified Username Field Change
2004-12-27 05:09 boerema1 New Issue
2004-12-29 03:08 boerema1 Note Added: 0006028
2005-01-02 09:10 anonymous Note Added: 0006059
2005-01-03 03:09 boerema1 Note Added: 0006063
2005-01-03 05:07 AHUser Status new => resolved
2005-01-03 05:07 AHUser Resolution open => fixed
2005-01-03 05:07 AHUser Assigned To => AHUser
2005-01-03 05:07 AHUser Assigned To AHUser =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker