Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002458 [JEDI VCL] 00 JVCL Components minor always 2005-01-02 20:36 2005-01-03 05:01
Reporter musictronics View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002458: Bug in JvEdit
Description When editing text in a JvEdit component the caret always jumps to the end of the text after one keystroke. The problem seems to be with the following line:
"SelStart := Length(Text);" in procedure TJvCustomEdit.Change; in JvEdit.pas
Commenting out the line gets rid of the problem.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006065)
AHUser (developer)
2005-01-03 05:01

Fixed in CVS.
Because the SelStart property is changed by "Text := " it has not worked.

Replaced by:

Sel := SelStart;
Text := St;
SelStart := Min(Sel, Length(St));

- Issue History
Date Modified Username Field Change
2005-01-02 20:36 musictronics New Issue
2005-01-03 05:01 AHUser Status new => resolved
2005-01-03 05:01 AHUser Resolution open => fixed
2005-01-03 05:01 AHUser Assigned To => AHUser
2005-01-03 05:01 AHUser Note Added: 0006065
2005-01-03 05:01 AHUser Assigned To AHUser =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker