Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002467 [JEDI VCL] 00 JVCL Components minor always 2005-01-04 09:00 2005-08-10 04:02
Reporter robert_marquardt View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002467: possible bug TJvDatabaseCopyAction.CopyRecord in JvDBActions.pas
Description   if Assigned(FBeforeCopyRecord) then
    FBeforeCopyRecord(DataSet, Allowed);
  with DataSet do
  begin
    // (rom) this suppresses AfterCopyRecord. Is that desired?
    if not Allowed then
      Exit;

This code does not always throw an AfterCopyRecord event.
Is this really desired?
Either no BeforeCopyEvent or an AfterCopyEvent with a failure signal would be better.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006081)
jfudickar (developer)
2005-01-04 10:56

I'm not shure. For me it's a point of design.

Both ways are correct. I say, that the developer has to handle everything in the BeforeCopyRecord Event. If he didn't want to continue, than he had to look after this and for me there is no reason to call the AfterCopyRecord event.

And the BeforeCopy-Event mus be called, because only there i got the informations about the "allowed".
(0007778)
obones (administrator)
2005-08-10 04:02

No answers, no decisions, I'm closing the issue.

- Issue History
Date Modified Username Field Change
2005-01-04 09:00 robert_marquardt New Issue
2005-01-04 10:56 jfudickar Note Added: 0006081
2005-01-04 10:56 jfudickar Issue Monitored: jfudickar
2005-01-05 03:07 jfudickar Status new => assigned
2005-01-05 03:07 jfudickar Assigned To => jfudickar
2005-01-05 03:08 jfudickar Status assigned => feedback
2005-08-10 04:02 obones Status feedback => resolved
2005-08-10 04:02 obones Resolution open => fixed
2005-08-10 04:02 obones Note Added: 0007778


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker