Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002469 [JEDI VCL] 02 Installation block always 2005-01-04 10:18 2005-01-04 15:35
Reporter iubito View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002469: compiling JvGlobusD7R.dpk(47) fatal: Packet required 'vclie' not found
Description Hi !

This morning I downloaded
JVCL300BETA2JCL192-Build1666Complete.zip
I unzipped it, installed JCL: OK
But JVCL fails.

In the install options, I choosed "Build packages".
I tried several times, always block.

Here is the result I get :
An error occured while compiling package
JvGlobusD7R.dpk(47) Fatale: Paquet requis 'vclie' non trouvé
translated in english it is :
JvGlobusD7R.dpk(47) Fatal: Packet required 'vclie' not found
Additional Information Here's the complete output

Windows 2000 Service Pack 4 (5.0.2195)

MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
[Generating: Templates]
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
Writing: ..\D7\dcc32.cfg
[Generating: Packages]
Generating packages for D7
    Loaded template.dof
    Loaded template.dpk
    Loaded template.res
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
[Compiling: Packages]
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
[Compiling: Jv3rdD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
4832 lignes, 0.48 secondes, 26952 octets de code, 117 octets de données.
[Compiling: JvCoreD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
146950 lignes, 3.84 secondes, 605280 octets de code, 4277 octets de données.
[Compiling: JvSystemD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
82657 lignes, 3.14 secondes, 248060 octets de code, 3013 octets de données.
[Compiling: JvStdCtrlsD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
153645 lignes, 4.99 secondes, 587020 octets de code, 3741 octets de données.
[Compiling: JvAppFrmD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
21302 lignes, 1.67 secondes, 42676 octets de code, 221 octets de données.
[Compiling: JvCoreD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
49262 lignes, 2.59 secondes, 83976 octets de code, 621 octets de données.
[Compiling: JvAppFrmD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
7051 lignes, 2.36 secondes, 13604 octets de code, 169 octets de données.
[Compiling: JvBandsD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
5420 lignes, 1.78 secondes, 25788 octets de code, 149 octets de données.
[Compiling: JvBandsD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
5683 lignes, 1.77 secondes, 11488 octets de code, 201 octets de données.
[Compiling: JvCtrlsD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
99717 lignes, 3.56 secondes, 352840 octets de code, 1597 octets de données.
[Compiling: JvDBD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
71118 lignes, 3.67 secondes, 317480 octets de code, 1325 octets de données.
[Compiling: JvDlgsD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
63057 lignes, 3.08 secondes, 200004 octets de code, 3173 octets de données.
[Compiling: JvBDED7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
27752 lignes, 2.48 secondes, 102220 octets de code, 449 octets de données.
[Compiling: JvDBD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
12848 lignes, 3.48 secondes, 24416 octets de code, 261 octets de données.
[Compiling: JvBDED7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
6590 lignes, 2.66 secondes, 8764 octets de code, 161 octets de données.
[Compiling: JvCmpD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
32946 lignes, 2.00 secondes, 74932 octets de code, 433 octets de données.
[Compiling: JvCmpD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
8637 lignes, 2.31 secondes, 16224 octets de code, 233 octets de données.
[Compiling: JvCryptD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
9057 lignes, 1.95 secondes, 37120 octets de code, 1757 octets de données.
[Compiling: JvCryptD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
2597 lignes, 1.89 secondes, 4156 octets de code, 153 octets de données.
[Compiling: JvCtrlsD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
14456 lignes, 2.97 secondes, 24992 octets de code, 309 octets de données.
[Compiling: JvCustomD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
96403 lignes, 3.20 secondes, 486516 octets de code, 1537 octets de données.
[Compiling: JvCustomD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
13766 lignes, 2.72 secondes, 32384 octets de code, 281 octets de données.
[Compiling: JvDlgsD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
8148 lignes, 2.33 secondes, 9632 octets de code, 181 octets de données.
[Compiling: JvDockingD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
47491 lignes, 2.09 secondes, 247856 octets de code, 693 octets de données.
[Compiling: JvDockingD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
4078 lignes, 1.45 secondes, 5452 octets de code, 157 octets de données.
[Compiling: JvDotNetCtrlsD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
5981 lignes, 2.16 secondes, 20752 octets de code, 157 octets de données.
[Compiling: JvDotNetCtrlsD7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
2618 lignes, 2.41 secondes, 5356 octets de code, 149 octets de données.
[Compiling: JvEDID7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
3304 lignes, 1.28 secondes, 29952 octets de code, 153 octets de données.
[Compiling: JvEDID7D.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
2589 lignes, 1.70 secondes, 3560 octets de code, 133 octets de données.
[Compiling: JvGlobusD7R.bpl]
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
JvGlobusD7R.dpk(47) Fatale: Paquet requis 'vclie' non trouvé

** error 1 ** deleting JvGlobusD7R.bpl

** error 1 ** deleting CompilePackages
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006082)
AHUser (developer)
2005-01-04 11:20

You do not have the Internet Components installed (TWebBrowser) which come with Delphi 7.
If you do not use the Globus components uncheck them in the package selection page of the JVCL Installer.
(0006085)
iubito (reporter)
2005-01-04 12:11

I installed TWebBrowser
Componants > install ActiveX > I choosed Microsoft Internet Explorer > Install
Now I have TWebBrowser.

But the error is still there :
JvGlobusD7R.dpk(47) Fatale: Paquet requis 'vclie' non trouvé

What can I do if I want to use Globus ?
(0006086)
AHUser (developer)
2005-01-04 12:44

Now you have a self compiled unit but not the VCLIE packages which can be installed by the Delphi 7 MSI installer.

Are you sure that you want to use the Globus components? They are only included for legacy. They are not really supported by the JVCL team. And most of the Globus components have a better corresponding "native" JVCL component.
(0006087)
iubito (reporter)
2005-01-04 12:57

OK I try to remove Globus.
but can't the installer bypass such error and continue to compile what it could, and then show errors at the end?

But now here is another problem :
JvInterpreterD7R.dpk(53) Fatale: Paquet requis 'inet' non trouvé
(0006089)
AHUser (developer)
2005-01-04 13:30

This is the same issue.

And what would be the benefit if the installer bypassed the error but cannot compile the other packages due to this error? More errors which have their origin in the first error.

Either you install the packages from your Delphi 7 CD, or we have to add another {$define xx} to the jvcl.inc files (which is be the prefered way for the future).
(0006091)
AHUser (developer)
2005-01-04 15:35

Fixed in CVS with Installer autodetecting if the inet and vclie packages are installed.

- Issue History
Date Modified Username Field Change
2005-01-04 10:18 iubito New Issue
2005-01-04 11:20 AHUser Note Added: 0006082
2005-01-04 12:11 iubito Note Added: 0006085
2005-01-04 12:44 AHUser Note Added: 0006086
2005-01-04 12:57 iubito Note Added: 0006087
2005-01-04 13:30 AHUser Note Added: 0006089
2005-01-04 15:35 AHUser Status new => resolved
2005-01-04 15:35 AHUser Resolution open => fixed
2005-01-04 15:35 AHUser Assigned To => AHUser
2005-01-04 15:35 AHUser Note Added: 0006091
2005-01-04 15:35 AHUser Assigned To AHUser =>


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker