Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002490 [JEDI VCL] 00 JVCL Components minor always 2005-01-08 08:41 2005-02-04 03:13
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002490: TjvCalcEdit problems
Description Found two problems with the TjvCalcEdit component.
1. I'm trying to use several components from the "jv Edits" tab. Since i need to treat them uniformly, i'm typecasting them to the common ancestor : TCustomEdit.

Everything is ok when i'm using tJvCalcEdit directly, but casting them to TCustomEdit, the Text property doesn't work. Example :
...
  var
  myEdit : TCustomEdit;
  myJVCalcEdit : TJvCalcEdit;
  ...
  myEdit := TCustomEdit(myJvCalcEdit);
  ...
  myJVCalcEdit.text := '123'; // works ok
  myEdit.text := '456'; //doesn't work... the assignment got ignored
...
This is probably caused by the component overriding the property or something, but I haven't delved into the code yet. Workaround at the moment is special-case handling of TjvCalcEdit... would love to get rid of this hack...:)

...
  for i:= tcomponentlist.items[i].count-1 do begin
    myEdit := tcomponentlist.items[i] as tCustomEdit;
    if (myEdit is tJvCalcEdit) then begin
       //special case
    end else begin
       //normal case
    end;
  end;
...

  
2. Event onChange() doesn't fire when users are entering data through the 'calculator' instead of typing it directly. This should be easy enough to verify.











Additional Information Tested on Delphi 6.02
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006389)
obones (administrator)
2005-02-04 03:13

1. This is what it is supposed to do

2. This is now fixed in CVS

- Issue History
Date Modified Username Field Change
2005-01-08 08:41 anonymous New Issue
2005-02-04 03:13 obones Status new => resolved
2005-02-04 03:13 obones Fixed in Version => 3.00
2005-02-04 03:13 obones Resolution open => fixed
2005-02-04 03:13 obones Assigned To => obones
2005-02-04 03:13 obones Note Added: 0006389


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker