Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002491 [JEDI VCL] 00 JVCL Components minor always 2005-01-08 15:01 2006-04-05 01:19
Reporter anonymous View Status public  
Assigned To ogiesen
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002491: TJvDatePickerEdit Problems
Description 1. The component resets the DATE property values on runtime so that the values set on design times were lost. Very annoying behaviour.

2. On design time, cut and pasting the component (even to the same container) exhibits the same behaviour (i.e. resetting the property value to TODAY's date), and also changed its width. Try selecting two of them, cut, and paste to the same form, the second one's width will be larger by one.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006232)
ogiesen (developer)
2005-01-19 14:10

Concerning 1. there is a special property called "StoreDate" which should take care of this. I will investigate the cut&paste width issue as soon as I have some time, hopefully this week.
(0007249)
obones (administrator)
2005-05-19 08:16

Any news on this Oliver ?
(0007252)
ogiesen (developer)
2005-05-19 09:04

Sorry, no. Unfortunately I have become pretty much detached from the components I once donated over all the changes that were done by others in the meantime, some of which rather fundamental. Not saying the changes were bad at all, but I simply didn't have the time to keep up with them. :(
For our own apps we're still using a version from almost a year ago because the control temporarily got broken around that time and because at least there I feel I'm still in control...

I have a reevaluation of the current state set on my todo-ist however, and it's slowly moving to the top of the list as other stuff is being ticked off...
(0008784)
obones (administrator)
2006-03-31 05:17

1. As Oliver said, set StoreDate to True and it will work. I've added a bit of code to set it to true automatically when the date is set to anything but the current date

2. For this, a workaround has been put in place, it works ok now.
(0008931)
obones (administrator)
2006-04-05 01:19

This is now in CVS

- Issue History
Date Modified Username Field Change
2005-01-08 15:01 anonymous New Issue
2005-01-19 14:10 ogiesen Note Added: 0006232
2005-01-19 14:10 ogiesen Assigned To => ogiesen
2005-01-19 14:10 ogiesen Severity major => minor
2005-01-19 14:10 ogiesen Status new => assigned
2005-05-19 08:16 obones Note Added: 0007249
2005-05-19 09:04 ogiesen Note Added: 0007252
2006-03-31 05:17 obones Note Added: 0008784
2006-03-31 05:17 obones Status assigned => confirmed
2006-04-05 01:19 obones Status confirmed => resolved
2006-04-05 01:19 obones Resolution open => fixed
2006-04-05 01:19 obones Note Added: 0008931


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker