Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002512 [JEDI VCL] 00 JVCL Components major always 2005-01-16 06:11 2005-01-22 02:12
Reporter cab-dk View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002512: jvDBGrid will not accept any input in numeric and alfa fields
Description When trying to put input into the grid nothing happens!
But if I press F2 in as column - it's possible to input some values.

Additional Information Version

  UnitVersioning: TUnitVersionInfo = (
    RCSfile: '$RCSfile: JvDBGrid.pas,v $';
    Revision: '$Revision: 1.97 $';
    Date: '$Date: 2005/01/13 20:11:07 $';
    LogPath: 'JVCL\run'
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0002496closed TJvDBGrid auto edit cell disabled ? (JVCL 3.00 RC1 / Delphi 6 / w2k) 

-  Notes
(0006152)
cab-dk (reporter)
2005-01-16 07:33

I have found a workaround - but I cannot definitely say what to do. If I uncomment 3 lines I can do input.

In line 2124 jbDBGrid.pas:

  begin
// if not Assigned(FCurrentControl) then
// DoKeyPress(Msg)
// else
      inherited;

    if Assigned(FCurrentControl) then
      if FCurrentControl.Visible then
        PostMessage(FCurrentControl.Handle, WM_CHAR, Msg.CharCode, Msg.KeyData);
  end;
(0006162)
obones (administrator)
2005-01-17 02:54

Please try with the previous version (1.96) of that file and let me know how it goes.
Somehow the changes made in 1.97 deleted the fixes from 1.96
(0006173)
cab-dk (reporter)
2005-01-17 04:37

I have gone into CVS and can confirm that the lines in question are removed from 1.96 to 1.97(copy/paste don't look good - look in CVS).
And the interim fix I have come up with solves the problem.
Who has removed these lines intensionally?
 
Line 2121
 Line 2122
 
   end end
   else else
   begin begin
       if not Assigned(FCurrentControl) then
         DoKeyPress(Msg)
       else
     inherited; inherited;
    
     if Assigned(FCurrentControl) then if Assigned(FCurrentControl) then
     begin
       if FCurrentControl.Visible then if FCurrentControl.Visible then
         PostMessage(FCurrentControl.Handle, WM_CHAR, Msg.CharCode, Msg.KeyData); PostMessage(FCurrentControl.Handle, WM_CHAR, Msg.CharCode, Msg.KeyData);
     end
     else
       if not CanEditShow then
         DoKeyPress(Msg); // This is needed to trigger an onKeyPressed event when the field
                          // is not editable (the inherited function don't trigger it
                          // because editing is prohibited by the UseDefaultEditor function)
   end; end;
 end; end;
(0006174)
obones (administrator)
2005-01-17 04:58

This does not seem to be an intentional change, more like a mishap.
This is being addressed as I write these lines, and a new version (1.98) is already in CVS. It takes 4 to 5 hours for it to propagate to the anonymous server.
I'll close this issue when I get answers from the developer who accidently put the changes.
(0006175)
obones (administrator)
2005-01-17 06:07

This is resolved now in CVS. Please get the latest version (1.98) as soon as it is available.
Cheers

Olivier
(0006179)
cab-dk (reporter)
2005-01-17 08:43

Sorry, but this bug is wrong corrected, The lines in 2125 to 2127 doesn't exist in version 1.96 - and the bug is still there.
Delete the lines2125 to 2127:

    if not Assigned(FCurrentControl) then
      DoKeyPress(Msg)
    else

then all is okay.
But I don't know if this will affect, or has any connection with the code following (which is added from 1.96 to 1.97 line 2130-2132):

    if Assigned(FCurrentControl) then
      if FCurrentControl.Visible then
        PostMessage(FCurrentControl.Handle, WM_CHAR, Msg.CharCode, Msg.KeyData);
(0006227)
obones (administrator)
2005-01-19 02:27

Did you have a look at version 1.98 ?
(0006238)
cab-dk (reporter)
2005-01-21 08:42

I have now downloaded 1.98 and it works fine now.

Thanks.
(0006242)
obones (administrator)
2005-01-22 02:12

This is now fixed in CVS

- Issue History
Date Modified Username Field Change
2005-01-16 06:11 cab-dk New Issue
2005-01-16 07:33 cab-dk Note Added: 0006152
2005-01-17 02:54 obones Note Added: 0006162
2005-01-17 02:54 obones Status new => feedback
2005-01-17 03:07 obones Relationship added has duplicate 0002496
2005-01-17 04:37 cab-dk Note Added: 0006173
2005-01-17 04:58 obones Note Added: 0006174
2005-01-17 06:07 obones Status feedback => resolved
2005-01-17 06:07 obones Resolution open => fixed
2005-01-17 06:07 obones Assigned To => obones
2005-01-17 06:07 obones Note Added: 0006175
2005-01-17 08:43 cab-dk Status resolved => feedback
2005-01-17 08:43 cab-dk Resolution fixed => reopened
2005-01-17 08:43 cab-dk Note Added: 0006179
2005-01-19 02:27 obones Note Added: 0006227
2005-01-21 08:42 cab-dk Note Added: 0006238
2005-01-22 02:12 obones Status feedback => resolved
2005-01-22 02:12 obones Resolution reopened => fixed
2005-01-22 02:12 obones Note Added: 0006242


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker