Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002526 [JEDI VCL] 00 JVCL Components minor always 2005-01-18 10:00 2005-01-27 05:47
Reporter anonymous View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002526: 3.00 RC1 JvFormStorage does not restore forms with Postion property of poMainFormCenter
Description When you have a form with the Position property set to poMainFormCenter, the JvFormStorage component will not restore the form to a moved position, even though it saves the modified form position to the registry. Changing the Position property to poScreenCenter works, but this precludes the ability for as-yet-to-be-seen forms from staying relative to the Main Form until moved to another location or monitor (multi monitor seems to work fine).
Additional Information
Tags No tags attached.
Attached Files zip file icon FormStorageBug.zip [^] (8,984 bytes) 2005-01-20 15:43

- Relationships
related to 0002484resolvedjfudickar JvFormStorage and Position := poMainFormCenter 

-  Notes
(0006209)
JohnFriel (reporter)
2005-01-18 10:11

Sorry, forgot to logon before reporting this.
(0006210)
JohnFriel (reporter)
2005-01-18 10:20

I see where this was addressed in issue 0002484, but now it appears to be broken again... Maybe the fix applied on 1-9-05 needs to be reapplied for the next daily of 3.0RC1?
(0006235)
jfudickar (developer)
2005-01-20 15:43

Please try the attached sample.

For me it works. If not, could you please build an other sample and upload it.

Greetings
Jens
(0006239)
anonymous (viewer)
2005-01-21 14:24

I downloaded the attached filed of 2484 and did a build on my system. The problem is still there with property poMainFormCenter dialogs.

I'm using Delphi6 and WinXP Professional SP2.
(0006269)
jfudickar (developer)
2005-01-24 11:45

Could you please look into the file JvJVCLUtils.pas what the current version is on your system.
It should look like this:
// $Id: JvJVCLUtils.pas,v 1.157 2005/01/21 09:28:57 marquardt Exp $
(0006271)
JohnFriel (reporter)
2005-01-24 12:25

Mine says:
// $Id: JvJVCLUtils.pas,v 1.155 2004/12/26 15:10:37 marquardt Exp $

I checked sourceforge and see that 1/8/2005 is still the latest version posted (which is what I have). How do I download a current snapshot of JVCL with posted changes other than waiting for RC2? I'm guessing it is fixed somewhere online but I haven't figured out how to update what I have.
Thanks.
(0006273)
jfudickar (developer)
2005-01-24 13:28

Two Solutions:
1. Use anonymous cvs
2. Use Web CVS : http://cvs.sourceforge.net/viewcvs.py/jvcl/dev/JVCL3/run/JvJVCLUtils.pas?rev=1.157&view=log [^]

Greetings
Jens
(0006295)
anonymous (viewer)
2005-01-27 05:38

The 01/21 fixes to JvJVCLUtils.pas was the cure for this. I finally bit the bullet and learned all about CVS this week. I use TortoiseCSV now and can update from the server here. If I remember correctly, the nots on using CVS are incorrect here and had to change the server name to get it to work. But no matter, the poMainFormCenter bug is fixed.
Thanks!

- Issue History
Date Modified Username Field Change
2005-01-18 10:00 anonymous New Issue
2005-01-18 10:11 JohnFriel Issue Monitored: JohnFriel
2005-01-18 10:11 JohnFriel Note Added: 0006209
2005-01-18 10:20 JohnFriel Note Added: 0006210
2005-01-18 11:15 jfudickar Relationship added related to 0002484
2005-01-18 11:15 jfudickar Issue Monitored: jfudickar
2005-01-20 15:43 jfudickar File Added: FormStorageBug.zip
2005-01-20 15:43 jfudickar Note Added: 0006235
2005-01-20 15:43 jfudickar Status new => feedback
2005-01-21 14:24 anonymous Note Added: 0006239
2005-01-24 11:45 jfudickar Note Added: 0006269
2005-01-24 12:25 JohnFriel Note Added: 0006271
2005-01-24 13:28 jfudickar Note Added: 0006273
2005-01-24 16:36 jfudickar Status feedback => assigned
2005-01-24 16:36 jfudickar Assigned To => jfudickar
2005-01-24 23:35 jfudickar Status assigned => feedback
2005-01-27 05:38 anonymous Note Added: 0006295
2005-01-27 05:47 jfudickar Status feedback => resolved
2005-01-27 05:47 jfudickar Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker