Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002555 [JEDI VCL] 02 Installation minor always 2005-01-25 04:36 2005-02-03 00:30
Reporter Volker Pohlers View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002555: installation with thememanager fails
Description Installation with Thememanager fails:

[Compiling: JvCoreD5R.bpl]
Borland Delphi Version 13.0 Copyright (c) 1983,99 Inprise Corporation
JvCoreD5R.dpk(40) Fatal: Package 'ThemeManager5' wurde benötigt, konnte aber nicht gefunden werden

** error 1 ** deleting "d:\Programme\Borland\Delphi5\Projects\Bpl"\JvCoreD5R.bpl

because then real name is ThemeManagerD5, not ThemeManager5!
Additional Information In file jvcl\packages\xml\JvCore-R.xml I had changed line
    <Package Name="ThemeManager5" Targets="D5,D5s,C5,C5s" Condition="JVCLThemesEnabled"/>
to
    <Package Name="ThemeManagerD5" Targets="D5,D5s,C5,C5s" Condition="JVCLThemesEnabled"/>
and the installer had go on. But this ist not a good solution, I think.
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006280)
AHUser (developer)
2005-01-25 08:36

> because then real name is ThemeManagerD5, not ThemeManager5!

The name was ThemeManager5 and ThemeManager6 when we had added ThemeManager support. But the name has changed. Now there are the two "name-version" spread over the internet and we have to solve this issue. Either we get the "bug-report" from the people without the "D" or we get it from the people with the "D".
(0006343)
obones (administrator)
2005-02-03 00:30

JvCore-R.xml has been updated so that it requires people to update the ThemeManager packages as well.
Changelog.txt mentions this.

- Issue History
Date Modified Username Field Change
2005-01-25 04:36 Volker Pohlers New Issue
2005-01-25 08:36 AHUser Note Added: 0006280
2005-01-25 08:36 AHUser Status new => acknowledged
2005-02-03 00:30 obones Status acknowledged => resolved
2005-02-03 00:30 obones Resolution open => fixed
2005-02-03 00:30 obones Assigned To => obones
2005-02-03 00:30 obones Note Added: 0006343


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker