Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002566 [JEDI VCL] 00 JVCL Components minor always 2005-01-28 11:21 2005-02-01 16:19
Reporter diwic View Status public  
Assigned To remkobonte
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002566: TJvTrayIcon does not reappear after Logon/Logoff
Description I've connected my TJvTrayIcon to an interactive service. I want this icon to persist if you log off and log on again, which it does not. It sure has some handling for the TaskbarRestart message, but it seems like this does not work,
perhaps because there is an WM_ENDSESSION first that hides the icon.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006330)
remkobonte (developer)
2005-02-01 16:19

I'm not sure whether the handling of WM_ENDSESSION is necessairy. Anyway the bug was in the handling of the TaskbarRestartMsg (tisTrayIconVisible flag was not set in FState because of the WM_ENDSESSION handling, so the icon was *not* restored).

This should be fixed in Rev. 1.37

- Issue History
Date Modified Username Field Change
2005-01-28 11:21 diwic New Issue
2005-01-28 11:21 diwic View Status private => public
2005-01-28 11:43 diwic Issue Monitored: diwic
2005-01-30 09:23 remkobonte Status new => assigned
2005-01-30 09:23 remkobonte Assigned To => remkobonte
2005-02-01 16:19 remkobonte Status assigned => resolved
2005-02-01 16:19 remkobonte Fixed in Version => 3.00
2005-02-01 16:19 remkobonte Resolution open => fixed
2005-02-01 16:19 remkobonte Note Added: 0006330


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker