Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002579 [JEDI VCL] 04 Feature Request minor always 2005-01-31 01:18 2005-02-27 14:01
Reporter carlosw View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002579: Minor improvements for JvDynControlEngineDBTools.pas
Description 1) TJvDynControlDataSourceEditDialog.CreateDynControlDialog:
- All 3 buttons are created as <Default> buttons. this is incorrect IMHO
- Only the CloseButton should be created as <Default> and <Cancel>

2) TJvDynControlDataSourceEditDialog.ShowDialog:
- The Mainpanel should receive the focus
    // Give the MainPanel the focus
    MainPanel.TabOrder := 0;
    Result := FForm.ShowModal;

3) Ability to put an image on the buttons
4) Enable/Disable reasons for the buttons ala JvParameterList :)
Additional Information Implementation for 3) Ability to put an image on the buttons
in TJvDynControlDataSourceEditDialog.CreateDynControlDialog

  if CloseButtonCaption <> '' then
  begin
    CloseButton := DynControlEngine.CreateButton(Form, FButtonPanel, '', CloseButtonCaption, '', OnCloseButtonClick,
      True, False);
    FButtonPanel.Height := CloseButton.Height + ArrangeSettings.BorderTop * 2;
    CloseButton.Top := ArrangeSettings.BorderTop;
    CloseButton.Anchors := [akTop, akRight];
    CloseButton.Left := LeftPos - CloseButton.Width - ArrangeSettings.BorderLeft;
    LeftPos := CloseButton.Left;
    CloseButton.TabOrder := 0;
++ if Supports(CloseButton, IJvDynControlButton, IJvButton) then
++ with IJvButton do
++ ControlSetGlyph(CloseButtonGlyph);
  end;
  if CancelButtonCaption <> '' then
  begin
    CancelButton := DynControlEngine.CreateButton(Form, FButtonPanel, '', CancelButtonCaption, '', OnCancelButtonClick,
      False, True);
    FButtonPanel.Height := CancelButton.Height + ArrangeSettings.BorderTop * 2;
    CancelButton.Top := ArrangeSettings.BorderTop;
    CancelButton.Anchors := [akTop, akRight];
    CancelButton.Left := LeftPos - CancelButton.Width - ArrangeSettings.DistanceHorizontal;
    LeftPos := CancelButton.Left;
    CancelButton.TabOrder := 0;
++ if Supports(CancelButton, IJvDynControlButton, IJvButton) then
++ with IJvButton do
++ ControlSetGlyph(CancelButtonGlyph);
  end;
  if PostButtonCaption <> '' then
  begin
    PostButton := DynControlEngine.CreateButton(Form, FButtonPanel, '', PostButtonCaption, '', OnPostButtonClick, False,
      False);
    FButtonPanel.Height := PostButton.Height + ArrangeSettings.BorderTop * 2;
    PostButton.Top := ArrangeSettings.BorderTop;
    PostButton.Anchors := [akTop, akRight];
    PostButton.Left := LeftPos - PostButton.Width - ArrangeSettings.DistanceHorizontal;
    PostButton.TabOrder := 0;
++ if Supports(PostButton, IJvDynControlButton, IJvButton) then
++ with IJvButton do
++ ControlSetGlyph(PostButtonGlyph);
  end;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006445)
jfudickar (developer)
2005-02-09 17:09

1+2 done, but not uploaded because of problems with cvs
3 will follow

4. I don'T think so. Because i don't know how to define
(0006446)
carlosw (reporter)
2005-02-09 17:27

thanx

4. Yes. it's tricky :)
Maybe something like:
- The Save button is always disabled
- when the user edits a field the Save button is enabled
(0006497)
jfudickar (developer)
2005-02-15 15:56

Everything changed and added. Please give it a try.

Point 3 is not available through the simple function, only by using the Component.

Point 4 is realized using JvDBActions :-) (I like my own creations :-)
(0006607)
jfudickar (developer)
2005-02-27 14:01

Done

- Issue History
Date Modified Username Field Change
2005-01-31 01:18 carlosw New Issue
2005-02-03 00:37 obones Status new => assigned
2005-02-03 00:37 obones Assigned To => jfudickar
2005-02-09 17:09 jfudickar Note Added: 0006445
2005-02-09 17:10 jfudickar Issue Monitored: jfudickar
2005-02-09 17:27 carlosw Note Added: 0006446
2005-02-15 15:56 jfudickar Note Added: 0006497
2005-02-15 15:56 jfudickar Status assigned => feedback
2005-02-27 14:01 jfudickar Status feedback => resolved
2005-02-27 14:01 jfudickar Fixed in Version => 3.00
2005-02-27 14:01 jfudickar Resolution open => fixed
2005-02-27 14:01 jfudickar Note Added: 0006607


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker