Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002588 [JEDI VCL] 00 JVCL Components minor always 2005-02-02 08:12 2005-04-12 08:57
Reporter CCR View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002588: Add caCharset to TJvConsistentAttribute in JvRichEdit.pas, like this...
Description 1) Append caCharset to TJvConsistentAttribute.
2) Add to TJvTextAttributes.GetConsistentAttributes, immediately below the check for caHidden:

      if (dwMask and CFM_CHARSET) <> 0 then
        Include(Result, caCharset);
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006349)
obones (administrator)
2005-02-03 00:42

What's the point of this change?
(0006414)
CCR (reporter)
2005-02-04 20:46

Because all the other elements of the 'native' enumeration (namely, CFM_XXX) are surfaced in TJvConsistentAttribute - so why not poor old CFM_CHARSET too? After all, TJvTextAttributes does have a Charset property.
(0006974)
obones (administrator)
2005-04-12 08:57

Thanks, this is now in CVS (revision 1.70)

- Issue History
Date Modified Username Field Change
2005-02-02 08:12 CCR New Issue
2005-02-03 00:42 obones Note Added: 0006349
2005-02-03 00:42 obones Status new => feedback
2005-02-04 20:46 CCR Note Added: 0006414
2005-04-12 08:57 obones Status feedback => resolved
2005-04-12 08:57 obones Resolution open => fixed
2005-04-12 08:57 obones Assigned To => obones
2005-04-12 08:57 obones Note Added: 0006974


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker