Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002598 [JEDI VCL] 02 Installation crash always 2005-02-03 18:53 2006-10-09 02:01
Reporter anonymous View Status public  
Assigned To delphi32
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0002598: Can not install JVCL 3 RC1
Description I can't install the JVCL3 RC1. The instalation process stop here:

Using d7 for build process.

MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
[Preprocessing JVCL]
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
[Generating MO files]
[Compiling: Installer]
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
Writing: ..\..\install\JVCLInstall\JVCLInstall.cfg
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
Fatal: Could not create output file 'JVCLInstall.str'

** error 1 ** deleting Installer_nomo
Press ENTER to continue
Additional Information The JCL install process stop here:

build.exe found. Pretest: ok
Using d7 for build process.

MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
        cd ..
cleaning up first...
        del /f /s *.~* bin\*.dll *.a *.bpi *.dcp *.dcu *.dpu *.hpp *.jdbg *.map
*.o
Não foi possível encontrar C:\DELPHI7\JEDISUX\jcl\*.~*
Não foi possível encontrar C:\DELPHI7\JEDISUX\jcl\bin\*.dll
Não foi possível encontrar C:\DELPHI7\JEDISUX\jcl\*.a
        cd lib
        del /f /s *.obj *.res
Não foi possível encontrar C:\DELPHI7\JEDISUX\jcl\lib\*.obj
        cd ..\install
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
JediInstaller.dpr(13) Fatal: Could not create output file 'JediInstaller.drf'

** error 1 ** deleting ..\bin\JediInstaller.exe

** error 1 ** deleting installer
Press ENTER to continue
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006371)
obones (administrator)
2005-02-03 23:54

Please ensure you have write access to all directories used by the JCL, the JVCL and Delphi. Please also ensure you have enough free disk space.
(0006411)
anonymous (viewer)
2005-02-04 16:54

Yes, I have write access to all directories used by JCL and JVCL, and I have 2,50GB of free space. I install the JCL and the JVCL by building the packages, so, I think this is an installer bug.
(0006416)
AHUser (developer)
2005-02-05 03:01

It is not an installer bug because the installer could not be compiled.
(0006431)
obones (administrator)
2005-02-06 05:19

I'm closing this issue as it is obvious it is a user's installation misconfiguration.
Please fix your installation first. Ensure you have write access to the Delphi directory.
(0008070)
anonymous (viewer)
2005-11-01 12:40

Hello!

Please, I have too this problem at 2 weeks!! Please e realy need the Jedi VCL and JVCL...
What is the procedure for a manual instalation?
Thank you very much!!!

Palma
(0008071)
AHUser (developer)
2005-11-01 15:21

.drf and .str are files the compiler generates temporary. Maybe you should find out where the dcc32 compiler wants to create those files (this error never happend on my PC yet).

For this you could use FileMon: http://www.sysinternals.com/Utilities/Filemon.html [^]

And please report if you find something out.
(0008072)
AHUser (developer)
2005-11-01 15:36

Where does the environment variable TEMP points to? Do you have write access in that directory? If not than you should correct this.
(0008126)
obones (administrator)
2005-11-22 08:38

No answers in over two weeks, closing the issue
(0010321)
anonymous (viewer)
2006-10-06 08:19

I have the same problem, writeaccess in every directory and enough disk space. I installed the jcl successfully but the same mistake with the jvcl:

build.exe found. Pretest: ok
Using d7 for build process.

MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
[Generating MO files]
[Compiling: Installer]
MAKE Version 5.2 Copyright (c) 1987, 1998 Inprise Corp.
Writing: ..\..\install\JVCLInstall\JVCLInstall.cfg
Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
JVCLInstall.dpr(74) Fatal: Datei nicht gefunden: 'JvGnugettext.dcu'

** error 1 ** deleting Installer_nomo
Press ENTER to continue
(0010333)
obones (administrator)
2006-10-09 02:01

Please leave this issue closed, use the latest JVCL and create a NEW issue if the problem is still here.

- Issue History
Date Modified Username Field Change
2005-02-03 18:53 anonymous New Issue
2005-02-03 23:54 obones Note Added: 0006371
2005-02-04 16:54 anonymous Note Added: 0006411
2005-02-05 03:01 AHUser Note Added: 0006416
2005-02-06 05:19 obones Status new => resolved
2005-02-06 05:19 obones Resolution open => no change required
2005-02-06 05:19 obones Assigned To => obones
2005-02-06 05:19 obones Note Added: 0006431
2005-11-01 12:40 anonymous Assigned To obones => delphi32
2005-11-01 12:40 anonymous Status resolved => feedback
2005-11-01 12:40 anonymous Resolution no change required => reopened
2005-11-01 12:40 anonymous Note Added: 0008070
2005-11-01 15:21 AHUser Note Added: 0008071
2005-11-01 15:36 AHUser Note Added: 0008072
2005-11-22 08:38 obones Status feedback => resolved
2005-11-22 08:38 obones Resolution reopened => fixed
2005-11-22 08:38 obones Note Added: 0008126
2006-10-06 08:19 anonymous Status resolved => feedback
2006-10-06 08:19 anonymous Resolution fixed => reopened
2006-10-06 08:19 anonymous Note Added: 0010321
2006-10-09 02:01 obones Status feedback => closed
2006-10-09 02:01 obones Note Added: 0010333
2006-10-09 02:01 obones Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker