Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002599 [JEDI VCL] 00 JVCL Components major always 2005-02-04 01:40 2005-02-12 09:11
Reporter obones View Status public  
Assigned To obones
Priority urgent Resolution fixed  
Status resolved   Product Version
Summary 0002599: OnEnter/OnExit do not occur if JvIPAddress is on the form
Description Hi

Drop JVCL components on the form and assign their OnEnter/OnExit to show a message box.
See that nothing happens when the focus shifts from one control to the next.
The attached example shows it with two controls, based on latest CVS version.
Additional Information
Tags No tags attached.
Attached Files zip file icon onenter_onexit.zip [^] (3,234 bytes) 2005-02-04 01:40

- Relationships
parent of 0002564closed TJvIPAddress OnExit event doesn`t Occur when the input focus shifts away from one control to another 

-  Notes
(0006420)
remkobonte (developer)
2005-02-05 05:03

Solution might be to add

      EN_SETFOCUS:
        Perform(WM_SETFOCUS, 0, 0);

to TJvIPAddress.CNCommand.

Don't know why the ip control does not receive a WM_SETFOCUS.
(0006471)
obones (administrator)
2005-02-12 09:11

The solution was indeed that, with a little precaution related to mouse focusing (see source for details).
As to why TJvIPAddress does not receive the message in the first place, I suspect it is because the embedded edits are not children of the control from Delphi's point of view.

- Issue History
Date Modified Username Field Change
2005-02-04 01:40 obones New Issue
2005-02-04 01:40 obones File Added: onenter_onexit.zip
2005-02-04 01:42 obones Relationship added parent of 0002564
2005-02-05 05:03 remkobonte Note Added: 0006420
2005-02-12 02:58 obones Assigned To => obones
2005-02-12 02:58 obones Status new => assigned
2005-02-12 02:58 obones Summary OnEnter/OnExit do not occur for most JVCL Components => OnEnter/OnExit do not occur if JvIPAddress is on the form
2005-02-12 09:11 obones Status assigned => resolved
2005-02-12 09:11 obones Fixed in Version => 3.00
2005-02-12 09:11 obones Resolution open => fixed
2005-02-12 09:11 obones Note Added: 0006471


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker