Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002603 [JEDI VCL] 00 JVCL Components minor always 2005-02-04 13:03 2006-06-08 02:36
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002603: JvMainMenu appear white in standard style under XP
Description As shown in the attachement, except under xp Style (or XP ItemPainter) the menu appears white in other styles, Standard, Button, Office, i don't know whether it is a bug or a default behaviour that may be changed, also with the XPManifest on the form, for me this appearance is not user friendly, this happens in the beta versions and the RC1..
Additional Information
Tags No tags attached.
Attached Files jpg file icon Mm.jpg [^] (26,912 bytes) 2005-02-04 13:03
jpg file icon p1.JPG [^] (16,969 bytes) 2005-04-15 14:16
jpg file icon menu.JPG [^] (59,393 bytes) 2005-04-15 14:21

- Relationships

-  Notes
(0006410)
obones (administrator)
2005-02-04 15:31

If you remove the ThemeManager, does this goes away?
And does this happen with TMainMenu?
I suspect that the ThemeManager is making this happen.
(0006421)
anonymous (viewer)
2005-02-05 12:49

What is theme manager?
i put JvMainMenu and assgin the properties style and this happens,
if i use the itempainter, the same result,
with XPManifest no change, the same effect,
in installing jvcl, the checkbox theming is not checked because it is clearly indicated that only non D7 users should check it, i work with D7 update 7.1, but even without the update it occurs,
i will check if it ocurrs with MainMenu, but i don't think so
(0006435)
anonymous (viewer)
2005-02-07 05:12

it does not occur with TMainmenu
when i set xp with classic appereance this does not occur
is it a bug, or an error of mine?
(0006958)
obones (administrator)
2005-04-12 07:02

I'm sorry, but I can't reproduce this. I have three machines here with D7, and none of them display this behaviour.
Can you try with the very latest sources and let me know how it goes ?
(0007005)
anonymous (viewer)
2005-04-14 13:51

Ok I will try and post soon..
(0007015)
anonymous (viewer)
2005-04-15 14:24

Unfortunately as you can in the file menu.jpg the bug still exists, i use now the jvcl 3 stable, i compiled in a w2k pc and see the results in a xp pc, moreover there is sometimes the diference in the selecteing rext as it is appreciated clearly from the image..
(0008821)
obones (administrator)
2006-04-03 03:57

I'm definitely not seing this, even when compiled with D2006. Could you post a demo application with sources and the compiled version so that I can test on my machine here?
One more question: Could you verify that the system colors did not get changed?
(0009432)
obones (administrator)
2006-06-08 02:36

Well, no news, assuming this is fixed by the latest daily

http://jvcl.sf.net/daily/ [^]

- Issue History
Date Modified Username Field Change
2005-02-04 13:03 anonymous New Issue
2005-02-04 13:03 anonymous File Added: Mm.jpg
2005-02-04 15:31 obones Note Added: 0006410
2005-02-05 12:49 anonymous Note Added: 0006421
2005-02-07 05:12 anonymous Note Added: 0006435
2005-04-12 07:02 obones Note Added: 0006958
2005-04-12 07:02 obones Status new => feedback
2005-04-14 13:51 anonymous Note Added: 0007005
2005-04-15 14:16 anonymous File Added: p1.JPG
2005-04-15 14:21 anonymous File Added: menu.JPG
2005-04-15 14:24 anonymous Note Added: 0007015
2005-08-28 09:41 obones Status feedback => assigned
2005-08-28 09:41 obones Assigned To => obones
2006-04-03 03:57 obones Note Added: 0008821
2006-04-03 03:57 obones Status assigned => feedback
2006-06-08 02:36 obones Status feedback => resolved
2006-06-08 02:36 obones Resolution open => fixed
2006-06-08 02:36 obones Note Added: 0009432


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker