Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002613 [JEDI VCL] 00 JVCL Components feature always 2005-02-09 10:55 2005-07-25 05:34
Reporter rmcclintock View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002613: Add column names to first row of CSV export in TJvDBGridCSVExport
Description There are several components that allow data to be directly exported to a grid, each with a different target file type (csv, xls, doc, html and xml). If I export to the xls format, then in Excel, I will see column names for headings.

The CSV export does not add column names as a header row (makes sense to me that it would).
Additional Information In addition, the current algorithm for creating the export always leaves a comma at the end of each line, creating a scenario where there will always be an empty column (logically) at the end of each row. This will become more apparent of column headings are added.

Tags No tags attached.
Attached Files ? file icon JvDBGridExport.pas [^] (35,690 bytes) 2005-02-09 10:55

- Relationships

-  Notes
(0007246)
obones (administrator)
2005-05-19 07:23

A small demo application would be most welcome.
To anyone implementing this: Make it an option so that the user can choose to get the headers or not.
(0007604)
jfudickar (developer)
2005-07-24 10:29

It seems to be done, so i think we can close the case?

- Issue History
Date Modified Username Field Change
2005-02-09 10:55 rmcclintock New Issue
2005-02-09 10:55 rmcclintock File Added: JvDBGridExport.pas
2005-05-19 07:23 obones Note Added: 0007246
2005-05-19 07:23 obones Status new => acknowledged
2005-07-24 10:29 jfudickar Note Added: 0007604
2005-07-24 10:29 jfudickar Status acknowledged => feedback
2005-07-25 05:34 obones Status feedback => resolved
2005-07-25 05:34 obones Resolution open => fixed
2005-07-25 05:34 obones Assigned To => obones


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker