Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002632 [JEDI VCL] 99 Other minor always 2005-02-12 03:40 2005-04-12 06:36
Reporter maxis View Status public  
Assigned To
Priority normal Resolution open  
Status closed   Product Version
Summary 0002632: bugs in JvThumbView
Description 1) JvThumView don't fire event OnChange correctly. If want to see how changed Selected property you need use OnChange & OnClick together.
2) Don't recieve keyboard focus when mouse click. I use JvThumbView1->SetFocus() in OnClick event handler.
3) Filter property contain not supported extensions (as Gif and other). No FilterIndex property.
4) Not exist method to reread directory when you change filter. Only use
JvThumbView1->Directory = JvThumbView1->Directory;
5) OnGetTitle event never fire in when you use Directory. Only in AddFromFile.
I make some change in .pas file commented as //---max.
6) I make changes for firing OnChange when you change to directory without filtered graphic files.
7) I think, if you have same parameter list for event OnGetTitle in JvThumbnail and JvThumbView, you can assign handler when you create JvThumbnail. Event should be fire as later as possible because for making new Title I need information about image dimention and other. You should send to event handler only Self and created JvThumbnail with all presetted properties.
Additional Information
Tags No tags attached.
Attached Files ? file icon JvThumbViews.pas [^] (35,068 bytes) 2005-02-12 03:40

- Relationships
duplicate of 0002745resolvedobones bugs in JvThumbView & JvThumbView 

-  Notes
(0006953)
obones (administrator)
2005-04-12 06:36

This is a duplicate

- Issue History
Date Modified Username Field Change
2005-02-12 03:40 maxis New Issue
2005-02-12 03:40 maxis File Added: JvThumbViews.pas
2005-04-12 06:36 obones Relationship added duplicate of 0002745
2005-04-12 06:36 obones Status new => closed
2005-04-12 06:36 obones Note Added: 0006953


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker