Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002644 [JEDI VCL] 00 JVCL Components crash always 2005-02-14 08:08 2006-06-08 02:15
Reporter vlad View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002644: TJvPageManager.PageProxies - access violation
Description 1. Put the TJvPageManager object on the form
2. Open PageProxies window on Object Inspector
3. Press the Close button of the window
4. Click on the form - "Access violation..." message will appear.

Using JVCL300RC1.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006581)
obones (administrator)
2005-02-25 05:31

I just tried with Delphi 6 and 7 with the latest JVCL, I could not reproduce that bug.
Please check your test cases, and provide the exact message of the Access Violation
(0006589)
vlad (reporter)
2005-02-25 12:53

"Access violation at address 4003C035 in module 'rtl70.bpl'. Read of adress 0000000F"

Sometime the message doesn't appear, but usually it does (with different adresses). I'm doing exactly the steps I've described.

I use Delphi 7.

It could be also the reason of Delphi installation itself, because I noticed weird behavior (but not the same as this issue) of some components in design mode. But right now I don't have the possibility to reinstall it on my laptop.
(0006950)
obones (administrator)
2005-04-12 06:28

This actually just happened to me, and the AV is in rtl70.bpl
(0008756)
obones (administrator)
2006-03-30 06:50

I can't seem to be reproducing this in BDS2006 with the current version of the JVCL. Could you try again with a newer version?
(0009421)
obones (administrator)
2006-06-08 02:15

Well, no news, assuming this is fixed in the latest daily:

http://jvcl.sf.net/daily/ [^]

- Issue History
Date Modified Username Field Change
2005-02-14 08:08 vlad New Issue
2005-02-25 05:31 obones Note Added: 0006581
2005-02-25 05:31 obones Status new => feedback
2005-02-25 12:53 vlad Note Added: 0006589
2005-04-12 06:28 obones Note Added: 0006950
2005-04-12 06:28 obones Status feedback => confirmed
2006-03-30 06:50 obones Note Added: 0008756
2006-03-30 06:50 obones Status confirmed => feedback
2006-06-08 02:15 obones Status feedback => resolved
2006-06-08 02:15 obones Resolution open => fixed
2006-06-08 02:15 obones Assigned To => obones
2006-06-08 02:15 obones Note Added: 0009421


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker