Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002655 [JEDI VCL] 00 JVCL Components crash always 2005-02-19 04:46 2005-03-17 00:14
Reporter DSA JCR View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002655: JvAppXMLStorage.WhiteSpaceReplacement doesn't work with JVCL 3.00 RC 1
Description Hi all

I used, before JVC 3.00 RC1 version, an XML file to save the Form propierties of my app.
I used a JvAppXMLStorage comp. connected with a JvAppStorage, and works fine.

I have downloaded the version of Jedi of sourceforge (JVCL 3.00 RC 1 2005-01-08) and found the following problems:

1.- JvAppXMLStorage.WhiteSpaceReplacement has changed into StorageOptions, is OK.
  BUT, it cannot be accesible by code, only with the Inspector. So I cannot assign a value by code to this propierty. (before I assigned by code the values of jVAppXMLStorage).

2.- When I assign a value to this propierty WhiteSpaceReplacement=> '_' in the Inspector and run my app, I have the following exception "XML nodes cannot contain white space and the WhiteSpaceReplacement propierty is empty. Please set the WhiteSpaceReplacement propierty to a non empty value"
BUT, this is not true, if i see the propierty in my app. it has the value '_'.
I think is there a problem when the changes in this propierty.
Additional Information
Tags No tags attached.
Attached Files jpg file icon ExecError.jpg [^] (95,422 bytes) 2005-02-19 04:46

- Relationships
has duplicate 0002654closed JvAppXMLStorage.WhiteSpaceReplacement doesn't work with JVCL 3.00 RC 1 

-  Notes
(0006525)
DSA JCR (reporter)
2005-02-19 05:19

Heyyy it isn't a bug.

I`m sorry is working fine.

I had another JvAppXMLStorage in another unit that I haven`t seen.

sorry for the incovenience

Juan
(0006526)
DSA JCR (reporter)
2005-02-19 05:26

Hi again ;-)

the bug that is real is the one that it cannot be accesed the WhiteSpaceReplacement propierty by code.

this is true also in the last daily build (05/02/2005).

thanks
Juan
(0006553)
jfudickar (developer)
2005-02-23 15:10

Hi,

for point 1, try something similar:
TJvAppXMLStorageOptions(XMLStorage.StorageOptions).WhiteSpaceReplacement := 'XXX';

for point 2, i can't reproduce it. It's working here without problems.

Could you create a sample and attach it to the bug entry.

Greetings
Jens
(0006560)
anonymous (viewer)
2005-02-24 11:21

Hi

Point 2 is ok, I said in my first note that it was my mistake.

Point 1, I mean, when I am in a PAS file and write "TJvAppXMLStorageOptions."
(See the last ".") the normal situation is that when you press "." in a class the Delphi editor gives you the list of objects`/propierties of this class and you select one and follow.
But now in the object inspector you see that the WhiteSpaceReplacement propierty is inside StorageOptions, so you expect the following situation:

"TJvAppXMLStorageOptions." => Select object/propierty
"TJvAppXMLStorageOptions.StorageOptions." => Select object/propierty
"TJvAppXMLStorageOptions.StorageOptions.WhiteSpaceReplacement"

and follow developing.

Now this is not the behaviour. I think that is not normal to put something like
"TJvAppXMLStorageOptions(XMLStorage.StorageOptions).WhiteSpaceReplacement"
because I see in the object inspector another thing.

greetings
Juan
(0006562)
obones (administrator)
2005-02-25 03:49

That's because you didn't notice that the property is of type TJvAppStorageOptions, while the actual class used for XML is TJvAppXMLStorageOptions. The IDE will do the difference and show the values for the latter, but your code has to cope with this.
I've readded a property for this, but it is there for legacy purposes only.
(0006564)
jfudickar (developer)
2005-02-25 04:23

Maybe i can do something different this weekend. I will try it out and give you a feedback after that.
(0006603)
jfudickar (developer)
2005-02-27 09:10

Please have a look at the new code.

I've removed the code of olivier. My code is hopefully right now.

Greetings
Jens

- Issue History
Date Modified Username Field Change
2005-02-19 04:46 DSA JCR New Issue
2005-02-19 04:46 DSA JCR File Added: ExecError.jpg
2005-02-19 05:19 DSA JCR Note Added: 0006525
2005-02-19 05:26 DSA JCR Note Added: 0006526
2005-02-19 07:18 USchuster Relationship added has duplicate 0002654
2005-02-21 23:53 jfudickar Issue Monitored: jfudickar
2005-02-21 23:53 jfudickar Status new => assigned
2005-02-21 23:53 jfudickar Assigned To => jfudickar
2005-02-23 15:10 jfudickar Note Added: 0006553
2005-02-23 15:10 jfudickar Status assigned => feedback
2005-02-24 11:21 anonymous Note Added: 0006560
2005-02-25 03:49 obones Note Added: 0006562
2005-02-25 04:23 jfudickar Note Added: 0006564
2005-02-27 09:10 jfudickar Note Added: 0006603
2005-03-17 00:14 jfudickar Status feedback => resolved
2005-03-17 00:14 jfudickar Fixed in Version => 3.00
2005-03-17 00:14 jfudickar Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker