Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002660 [JEDI VCL] 00 JVCL Components minor always 2005-02-19 07:43 2005-02-22 08:21
Reporter grenzi_r View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002660: TJvHotLink does not execute the given URL any longer
Description Place a TJvHotLink on form and set the URL property to an valid URL and start the app and click at the link and see that nothing happens. In former times (when I develop the MegaDemo) the click takes me to the URL. It seems to be that the ShellExecute is cleared here
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006529)
AHUser (developer)
2005-02-19 11:03

TJvHotLink was merged with TJvLabel and there you have to set AutoOpenURL to true.
(0006539)
grenzi_r (developer)
2005-02-21 07:27

in That case I would suggest to set the default for AutoOpenURL to true
(0006540)
AHUser (developer)
2005-02-21 07:29

I don't think so because TJvLabel is not only a URL-Label. But introducing the side effect that makes AutoOpenURL=true if you change the URL property to something <> '' could be a solution.
(0006545)
grenzi_r (developer)
2005-02-22 02:45

Yes that sound very good to me
(0006546)
AHUser (developer)
2005-02-22 08:21

After looking more deeply into the code I think that a default AutoOpenURL=True is the better solution because it has less side effects and has a clearer implementation.


Fixed in CVS.

- Issue History
Date Modified Username Field Change
2005-02-19 07:43 grenzi_r New Issue
2005-02-19 11:03 AHUser Note Added: 0006529
2005-02-19 11:12 AHUser Status new => feedback
2005-02-21 07:27 grenzi_r Note Added: 0006539
2005-02-21 07:29 AHUser Note Added: 0006540
2005-02-22 02:45 grenzi_r Note Added: 0006545
2005-02-22 08:21 AHUser Status feedback => resolved
2005-02-22 08:21 AHUser Resolution open => fixed
2005-02-22 08:21 AHUser Assigned To => AHUser
2005-02-22 08:21 AHUser Note Added: 0006546


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker