Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002686 [JEDI VCL] 00 JVCL Components major always 2005-02-25 07:43 2006-06-27 03:41
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002686: TJvDBDateTimePicker broken in V3
Description - DropDownDate not working
- Exception opening DBDateTimePicker and closing without selecting a date

Alle bugs are related to jvdatetimepicker.pas and not jvdbdatetimerpicker.pas.
Everything works fine in JVCL V2.

Additional Information Workaround:
procedure TJvDateTimePicker.CNNotify(var Msg: TWMNotify):
1.
Delete the case-handlers NM_SETFOCUS and NM_KILLFOCUS (this repairs the dropdowndate issue because NullText ist set to '')
2.
There is a message with code (MCN_LAST + 6) which may not be handled by inherited.
Example:
      (MCN_LAST + 6):
       begin
         // ##has to be ignored
       end;
I don't know why.
Tags No tags attached.
Attached Files zip file icon jedibug_1.zip [^] (3,743 bytes) 2005-02-25 07:43

- Relationships
related to 0001922resolvedremkobonte Suggestions for TJvDateTimePicker and TJvDBDateTimePicker 

-  Notes
(0006592)
user72
2005-02-26 02:32

MCN_LAST + 6 == DTN_CLOSEUP
(0006602)
remkobonte (developer)
2005-02-27 07:45
edited on: 2005-02-27 10:57

What should be displayed in the TJvDateTimePicker control, when it is focused and Date equals NullDate?

(0006677)
user72
2005-03-10 14:22

NullText

I have verified that the proposed fix works, so I am planning to check it in. Any objections?
(0006681)
remkobonte (developer)
2005-03-10 15:13

Not really, but user tlsi2000 says in mantis 0001922 that the text of the TJvDateTimePicker control should not change to NullText while editing, so the NullDate functionality should be disabled while the control has focus.

This conficts with what anonymous proposes here, hence my question what should be displayed in the TJvDateTimePicker control, when it is focused and Date equals NullDate..

I can't reproduce the exception BTW.
(0006682)
user72
2005-03-10 15:36

Hm, could this be an OS issue? I get the AV here on W2k...
(0007064)
anonymous (viewer)
2005-04-25 06:23

For this bug just override function CheckNullValue which needs to be virtual.
So implement this code which consideers the Field as unexistent or Null :

function TJvDBDateTimePicker.CheckNullValue: Boolean;
begin
    Result := not assigned ( FDataLink.Field ) or FDataLink.Field.IsNull or CheckNullValue(NullText, Format, Kind, DateTime, NullDate) ;
end;
(0007727)
obones (administrator)
2005-08-09 07:02

anyone care to comment ?
(0008807)
obones (administrator)
2006-03-31 07:24

hello?
(0009663)
obones (administrator)
2006-06-27 03:41

Well, without any response, I'm assuming this is fixed in the latest development version. Should it not be the case, please provide a sample application and/or a diff file against the latest SVN content:

http://homepages.borland.com/jedi/wiki/index.php?title=Repository [^]

- Issue History
Date Modified Username Field Change
2005-02-25 07:43 anonymous New Issue
2005-02-25 07:43 anonymous File Added: jedibug_1.zip
2005-02-26 02:32 user72 Note Added: 0006592
2005-02-26 10:26 remkobonte Relationship added related to 0001922
2005-02-27 07:45 remkobonte Note Added: 0006602
2005-02-27 07:45 remkobonte Status new => feedback
2005-02-27 10:57 remkobonte Note Edited: 0006602
2005-03-10 14:22 user72 Note Added: 0006677
2005-03-10 15:13 remkobonte Note Added: 0006681
2005-03-10 15:36 user72 Note Added: 0006682
2005-04-25 06:23 anonymous Note Added: 0007064
2005-08-09 07:02 obones Note Added: 0007727
2006-03-31 07:24 obones Note Added: 0008807
2006-06-27 03:41 obones Status feedback => resolved
2006-06-27 03:41 obones Fixed in Version => Daily / SVN
2006-06-27 03:41 obones Resolution open => fixed
2006-06-27 03:41 obones Assigned To => obones
2006-06-27 03:41 obones Note Added: 0009663


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker