Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002703 [JEDI VCL] 00 JVCL Components crash always 2005-03-01 20:20 2005-04-12 06:10
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002703: Converting to TJvValidateEdit
Description TJvValidateEdit is a powerfull component. I really like it but there is some points:

- It should have Ctl3d and ParentCtl3D properties to keep compability. They are derivated from TWinControl so I guess it's easy to publish.

- When the you are converting (via JVCLConvert) TJvxCurrencyEdit to TJvValidateEdit and it has the property DisplayFormat set, Delphi 7 IDE show the error "Read from Stream" when loading DFM and crash. The problem is the property DisplayFormat has the same name in both components but has diferent types. TJvxCurrencyEdit.DisplayFormat is String and TJvValidate.DisplayFormat is Enumerated. Solution: Change TJvValidateEdit.DisplayFormat property name.

- Should be included in JVCL3.dat (JVCLConverter)
TJvxCurrencyEdit=TJvValidateEdit
TJvIntegerEdit=TJvValidateEdit
JvCurrEdit=JvValidateEdit
JvTypedEdit=JvValidateEdit

Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006946)
obones (administrator)
2005-04-12 06:10

1: This is already the case
2: Nothing we can do here
3: This is now in CVS.

- Issue History
Date Modified Username Field Change
2005-03-01 20:20 anonymous New Issue
2005-04-12 06:10 obones Status new => resolved
2005-04-12 06:10 obones Resolution open => fixed
2005-04-12 06:10 obones Assigned To => obones
2005-04-12 06:10 obones Note Added: 0006946


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker