Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002708 [JEDI VCL] 00 JVCL Components feature always 2005-03-02 15:56 2006-04-05 01:17
Reporter Randall Parker View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002708: Make full JvOfficeColorButton to toggle color pallette like Arrow Click does now
Description Currently a click anywhere on JvColorButton toggles its color pallette in and out of view. However the nicer color pallette of JvOfficeColorButton can be toggled in and out of view only by clicking on the down Arrow on the right side. I would like the click on the color area of the button to be configurable to toggle the pallette in and out of view.

Another option: Provide JvColorButton with the ability to use the color pallette from JvOfficeColorButton. However, JvOfficeColorButton has more events and is a richer control. Still, for my purposes just being able to use the JvOfficeColorButton pallette in JvColorButton would be adequate.
Additional Information Peter Thornqvist provided me with a partial implementation of this feature. However, in his implementation (included with his text below) the click on the color area will show the pallette. But a second click on the color button will not make the pallette disappear. The problem is that the down click causes the pallette to disappear. but then the call to ClickArrow in the up click event will cause the pallette to appear again. I implemented this code below and observed the lack of ability to make the second click hide the pallette.

Here is what he told me:

There is no simple "out of the box" solution. The best would be to add a
new, public procedure to the button:

procedure ClickArrow;

and implement like this:

procedure TJvCustomOfficeColorButton.ClickArrow;
begin
  if FArrowButton <> nil then
    FArrowButton.Click;
end;

then you could just call ClickArrow in the OnClick handler of the button:

procedure TForm1.JvOfficeColorButton1Click(Sender: TObject);
begin
  JvOfficeColorButton1.ClickArrow;
end;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0008744)
obones (administrator)
2006-03-30 04:28

I've added ButtonShowsPalette which defaults to True and tells to show the palette wherever the click occured.
I've added OnPaletteShowing event to allow user to control wether the palette is shown or not when it is about to be shown.
This will be in CVS as soon as Sourceforge fixes the "read-only" issue affecting it.
(0008922)
obones (administrator)
2006-04-05 01:17

This is now in CVS

- Issue History
Date Modified Username Field Change
2005-03-02 15:56 Randall Parker New Issue
2006-03-30 04:28 obones Note Added: 0008744
2006-03-30 04:28 obones Status new => confirmed
2006-04-05 01:17 obones Status confirmed => resolved
2006-04-05 01:17 obones Resolution open => fixed
2006-04-05 01:17 obones Assigned To => obones
2006-04-05 01:17 obones Note Added: 0008922


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker