Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002745 [JEDI VCL] 00 JVCL Components major always 2005-03-12 04:06 2006-06-27 03:31
Reporter maxis View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002745: bugs in JvThumbView & JvThumbView
Description 1) JvThumView don't fire event OnChange correctly. If want to see how changed Selected property you need use OnChange & OnClick together.
2) Don't recieve keyboard focus when mouse click. I use JvThumbView1->SetFocus() in OnClick event handler.
3) Filter property contain not supported extensions (as Gif and other). No FilterIndex property.
4) Not exist method to reread directory when you change filter. Only use
JvThumbView1->Directory = JvThumbView1->Directory;
5) OnGetTitle event never fire in when you use Directory. Only in AddFromFile.
6) I make changes for firing OnChange when you change to directory without filtered graphic files.
7) I think, if you have same parameter list for event OnGetTitle in JvThumbnail and JvThumbView, you can assign handler when you create JvThumbnail. Event should be fire as later as possible because for making new Title I need information about image dimention and other. You should send to event handler only Self and created JvThumbnail with all presetted properties.

In most cases I make some change in .pas file commented as //---max and attach it.
Additional Information
Tags No tags attached.
Attached Files zip file icon Thumbs.zip [^] (13,448 bytes) 2005-03-12 04:06

- Relationships
duplicate of 0002746closed bugs in JvThumbView & JvThumbView 
has duplicate 0002632closed bugs in JvThumbView 

-  Notes
(0008746)
obones (administrator)
2006-03-30 04:56

Does this still happen with the latest JVCL version?
If yes, can you provide a demo application showing the problem(s) along with a diff file with your changes (diff -u 3)?
Thanks
(0009653)
obones (administrator)
2006-06-27 03:31

Well, no answers, I'm assuming this is fixed in the latest version. Should it not be the case, please create a new issue, with a diff file against the current development version:

http://homepages.borland.com/jedi/wiki/index.php?title=Repository [^]

- Issue History
Date Modified Username Field Change
2005-03-12 04:06 maxis New Issue
2005-03-12 04:06 maxis File Added: Thumbs.zip
2005-03-14 08:51 jfudickar Relationship added duplicate of 0002746
2005-04-12 06:36 obones Relationship added has duplicate 0002632
2006-03-30 04:56 obones Note Added: 0008746
2006-03-30 04:56 obones Status new => feedback
2006-06-27 03:31 obones Status feedback => resolved
2006-06-27 03:31 obones Fixed in Version => Daily / SVN
2006-06-27 03:31 obones Resolution open => fixed
2006-06-27 03:31 obones Assigned To => obones
2006-06-27 03:31 obones Note Added: 0009653


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker