Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002751 [JEDI VCL] 00 JVCL Components minor always 2005-03-13 05:12 2005-03-14 00:31
Reporter remkobonte View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002751: Error with TJvCustomAppStorage and tkChar properties
Description From the newsgroup:

Hi, JVCL 3.0 March 10 daily build
When trying to save / load properties that are Char types using
WriteProperty / ReadProperty, an error is raised if the
StorageOptions.TypedIntegerAsString is True.
I hope that someone can help,
Cheers,
Andrew
Additional Information Reproduce this by dropping a TEdit and a TButton control on a form and write the code:

procedure TForm1.Button1Click(Sender: TObject);
begin
  with TJvAppXMLFileStorage.Create(nil) do
  try
    FileName := 'temp';
    StorageOptions.TypedIntegerAsString := True;
    WriteProperty('path1', Edit1, 'PasswordChar', False);

    // Exception in TJvCustomAppStorage.WriteEnumerationInt
    // TypeInfo.Kind = tkChar
  finally
    Free;
  end;
end;
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0002740resolvedjfudickar Problem saving Properties in TJvCustomAppStorage 

-  Notes
(0006696)
jfudickar (developer)
2005-03-13 13:07

Should be fixed. Please check
(0006701)
remkobonte (developer)
2005-03-13 14:23

Yup, works AFAICS.

- Issue History
Date Modified Username Field Change
2005-03-13 05:12 remkobonte New Issue
2005-03-13 12:46 jfudickar Relationship added duplicate of 0002740
2005-03-13 13:07 jfudickar Status new => assigned
2005-03-13 13:07 jfudickar Assigned To => jfudickar
2005-03-13 13:07 jfudickar Note Added: 0006696
2005-03-13 13:07 jfudickar Status assigned => feedback
2005-03-13 14:23 remkobonte Note Added: 0006701
2005-03-14 00:31 jfudickar Status feedback => resolved
2005-03-14 00:31 jfudickar Fixed in Version => 3.00
2005-03-14 00:31 jfudickar Resolution open => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker