Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002756 [JEDI VCL] 00 JVCL Components major always 2005-03-15 09:46 2005-03-15 12:04
Reporter tomatoman View Status public  
Assigned To user72
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002756: TJvStringGrid.SortGrid Fixed parameter interpretation mismatch
Description The SortGrid method in JVCL 2.1 interpreted the Fixed parameter as fixed columns (i.e. Fixed = true resulted in sorting the fixed column(s) as well).
This behaviour changed in 3.0 and now the Fixed parameter is used for columns as well as rows, making it impossible to sort a grid with 1 fixed row and 1 fixed column if one wants to include the fixed columns in the sort (but leave the fixed row alone).
See ExchangeGridRows where Fixed is applied to columns vs. InvertGrid where fixed is applied to rows.
Since SortGrid sorts only rows, it is unlikely that the fixed rows would ever need to be sorted, therefore the 2.1 code was correct (IMHO).
Modified unit included
Additional Information
Tags No tags attached.
Attached Files ? file icon JvStringGrid.pas [^] (41,624 bytes) 2005-03-15 09:46

- Relationships

-  Notes
(0006710)
user72
2005-03-15 11:59

Fixed in CVS (JVCL_300_PREPARATION branch)
(0006711)
user72
2005-03-15 12:04

Also updated in HEAD branch

- Issue History
Date Modified Username Field Change
2005-03-15 09:46 tomatoman New Issue
2005-03-15 09:46 tomatoman File Added: JvStringGrid.pas
2005-03-15 09:48 tomatoman Issue Monitored: tomatoman
2005-03-15 11:59 user72 Status new => resolved
2005-03-15 11:59 user72 Resolution open => fixed
2005-03-15 11:59 user72 Assigned To => user72
2005-03-15 11:59 user72 Note Added: 0006710
2005-03-15 12:04 user72 Note Added: 0006711
2005-03-29 18:14 tomatoman Issue End Monitor: tomatoman


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker