Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002781 [JEDI VCL] 00 JVCL Components crash always 2005-03-18 10:33 2005-03-18 11:20
Reporter wapostma View Status public  
Assigned To AHUser
Priority urgent Resolution fixed  
Status resolved   Product Version 3.00 BETA 2
Summary 0002781: JvAppEvents bug : JvAppInstances+JvAppEvents crash [access violation or runtime error 216]
Description Attached is a demo application. It contains a JvAppInstances component and a JvAppEvents component.

The second copy of this program you start, detects that it is a second copy (this is what JvAppInstances is supposed to do), and immediatley shuts down the application. This shutdown somehow does something to jvAppEvents, that causes it to crash. I am unable to figure out why since I don't understand jvAppEvents code. It dies accessing an invalid TList object, or an invalid index in a TList object, when destroying the components as they are destroyed from within TCustomForm.Destroy. Why this happens in this case, but doesn't happen if you remove the JvAppEvents object, I don't know, but I suspect a code problem in JvAppEvents.
Additional Information Steps to replicate:

(1) Build the EXE, but don't run it inside the IDE. Run the first copy NOT IN the Delphi debugger IDE but separately by double-clicking on the Exe file.

(2) Now run the second copy inside the delphi IDE, immediately at startup, it will begin application shutdown, and the main form will be destroyed, at this point, something goes screwy, and we get an acess violation.

On my system it doesn't just crash, it repeately crashes, and each time Windows puts up that message asking if you want to send in debugging information, and you select no, it crashes again. I haven't seen a crash this bad in a while.
Tags No tags attached.
Attached Files zip file icon JvAppInstanceCrash.zip [^] (4,435 bytes) 2005-03-18 10:33

- Relationships

-  Notes
(0006737)
AHUser (developer)
2005-03-18 11:20

Fixed in CVS

- Issue History
Date Modified Username Field Change
2005-03-18 10:33 wapostma New Issue
2005-03-18 10:33 wapostma File Added: JvAppInstanceCrash.zip
2005-03-18 11:20 AHUser Status new => resolved
2005-03-18 11:20 AHUser Resolution open => fixed
2005-03-18 11:20 AHUser Assigned To => AHUser
2005-03-18 11:20 AHUser Note Added: 0006737


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker