Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002802 [JEDI VCL] 00 JVCL Components feature always 2005-03-25 13:56 2005-05-18 07:02
Reporter anonymous View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 BETA
Summary 0002802: Formstorage does not restore last active TabSheet
Description After migrating from JVCL 2.1 to 3.0 and converting the JvFormStorage Components, restoring the last active TabSheet in an PageControl does not work as before, see attached sample application
Additional Information
Tags No tags attached.
Attached Files zip file icon Formstorage.zip [^] (1,747 bytes) 2005-03-25 13:56
zip file icon Formstorage_activecontrol.zip [^] (5,012 bytes) 2005-03-29 11:44

- Relationships

-  Notes
(0006773)
jfudickar (developer)
2005-03-29 11:46

The problem is the Property ActivePage. This can't be used in your way.

You had to use ActivePageIndex. And this property is not published.

I've added a changed sample, which shows a way, how this could be solved.

Please give me a feedback.
(0006777)
anonymous (viewer)
2005-03-29 23:03

Jens,
many thanks for your effort.
This is about the same I did before I discovered JVCL 2.1 and all the things it can do for me painlessly.
Don't remember if it was PageControl.AvtivePage I had to add to the stored properties or if it was enough to tick the checkbox ActiveControl in order to get the behavior in JVCL 2.1.
What is the purpose of that CheckBox ActiveControl anyway?
(0006778)
jfudickar (developer)
2005-03-30 00:35

Active Control is that the last focused control will be restored.

So but everything is fine and we can close this?
(0007209)
obones (administrator)
2005-05-18 07:02

No answers in a timely manner -> Resolved.

- Issue History
Date Modified Username Field Change
2005-03-25 13:56 anonymous New Issue
2005-03-25 13:56 anonymous File Added: Formstorage.zip
2005-03-29 11:44 jfudickar File Added: Formstorage_activecontrol.zip
2005-03-29 11:46 jfudickar Note Added: 0006773
2005-03-29 11:46 jfudickar Assigned To => jfudickar
2005-03-29 11:46 jfudickar Status new => feedback
2005-03-29 23:03 anonymous Note Added: 0006777
2005-03-30 00:35 jfudickar Note Added: 0006778
2005-05-18 07:02 obones Status feedback => resolved
2005-05-18 07:02 obones Resolution open => fixed
2005-05-18 07:02 obones Note Added: 0007209


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker