Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002827 [JEDI VCL] 00 JVCL Components minor always 2005-04-01 06:14 2005-05-18 06:29
Reporter gnatali View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002827: TJvErrorIndicator raise a "Thread error: The Parameter is incorrect (87)" error
Description When TJvErrorIndicator destroy the TJvBlinkThread instance in StopThread function, the exception is raised.

The execute function of TJvBlinkThread contient a call to sleep function.
Additional Information To correct this, remplace :
procedure TJvErrorIndicator.StopThread;
begin
  if FBlinkThread <> nil then
    FBlinkThread.Terminate;
  FreeAndNil(FBlinkThread);
end;

BY

procedure TJvErrorIndicator.StopThread;
begin
  if FBlinkThread <> nil then
  begin
    FBlinkThread.Terminate;
    FBlinkThread.WaitFor;
  end;
  FreeAndNil(FBlinkThread);
end;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0006824)
outchy (administrator)
2005-04-01 09:19

Fixed in the CVS version with :

procedure TJvErrorIndicator.StopThread;
begin
  if FBlinkThread <> nil then
  try
    FBlinkThread.Terminate;
    FBlinkThread.WaitFor;
  finally
    FreeAndNil(FBlinkThread);
  end;
end;
(0006894)
obones (administrator)
2005-04-11 06:22

This is very strange, because Free is calling Terminate then WaitFor if the thread is still running. Hence, there shouldn't be any need to actually ask for the thread to stop.
(0007198)
obones (administrator)
2005-05-18 06:29

Ah well, anyway, this is resolved.

- Issue History
Date Modified Username Field Change
2005-04-01 06:14 gnatali New Issue
2005-04-01 09:19 outchy Note Added: 0006824
2005-04-11 06:22 obones Note Added: 0006894
2005-05-18 06:29 obones Status new => resolved
2005-05-18 06:29 obones Resolution open => fixed
2005-05-18 06:29 obones Assigned To => obones
2005-05-18 06:29 obones Note Added: 0007198


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker