Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002866 [JEDI VCL] 00 JVCL Components feature always 2005-04-13 01:09 2005-04-14 17:33
Reporter TerminalMotion View Status public  
Assigned To outchy
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002866: TJVCombobox Readonly allows backspacing
Description When setting the readonly property, the control still allows backspacing. I've resolved it by adding "key = char(0)" to the Keypress event. Would be great if it was included.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007007)
outchy (administrator)
2005-04-14 17:06

Tested with D7 under Win 2000.
Seems to be a bug of VCL (of Borland), the procedure TCustomComboBox.KeyPress(var Key: Char) located in StdCtrls.pas doesn't check the ReadOnly flag of the edit and process the backspace key.
Your solution solves the problem. I will use and commit changes in the CVS repository.
Thanks for reporting the bug.
(0007008)
outchy (administrator)
2005-04-14 17:33

Fixed in the CVS, available for anonymous logins in some hours.

- Issue History
Date Modified Username Field Change
2005-04-13 01:09 TerminalMotion New Issue
2005-04-14 17:06 outchy Note Added: 0007007
2005-04-14 17:06 outchy Status new => confirmed
2005-04-14 17:10 outchy Status confirmed => assigned
2005-04-14 17:10 outchy Assigned To => outchy
2005-04-14 17:33 outchy Status assigned => resolved
2005-04-14 17:33 outchy Resolution open => fixed
2005-04-14 17:33 outchy Note Added: 0007008


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker