Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002896 [JEDI VCL] 00 JVCL Components minor always 2005-04-21 17:07 2005-04-22 06:05
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002896: TJvLabel with big fonts
Description Hi,

when I have TJvLabel and I put inside tahoma, 14px, bold, white + shadow blue, whole align Left. Then I resize a panel on which is this Label placed it drops the color and font. After setting of new text it works ok.

I thin it's only in visual, because when it's broken and I check the font, it returns correct value.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007035)
anonymous (viewer)
2005-04-21 17:13

I was playing a bit with that and it's not cause by the font. It's because I have an action onDoubleClick and I do doubleClick on this item. Then it loose font and color of the primary font.
(0007042)
obones (administrator)
2005-04-22 06:05

This is now fixed in CVS. The change is at line 593 in JvLabel.pas. The condition should be:

  if MouseOver and HotTrack then

Change this, recompile the JVCL and you should be sorted

- Issue History
Date Modified Username Field Change
2005-04-21 17:07 anonymous New Issue
2005-04-21 17:13 anonymous Note Added: 0007035
2005-04-22 06:05 obones Status new => resolved
2005-04-22 06:05 obones Resolution open => fixed
2005-04-22 06:05 obones Assigned To => obones
2005-04-22 06:05 obones Note Added: 0007042


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker