Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002919 [JEDI VCL] 00 JVCL Components major always 2005-04-28 09:31 2005-05-04 09:35
Reporter dbudelsky View Status public  
Assigned To jfudickar
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002919: TJvCustomAppMemoryFileStorage stores only one form
Description When using the same filename in TJvCustomAppMemoryFileStorage for
more than one form, only the data of one form is stored, usually the
main form.

I tried this with TJvAppIniFileStorage and TJvAppXMLFileStorage.

Additionally, when using a TJvAppIniFileStorage, other data in the
INI file, not handled by TJvCustomAppMemoryFileStorage is reset to
the values at program start, all changes made inbetween are lost.

The new components are not usable for handling multiwindows applications.
As I want to control the settings of several program instances by config
files, using one file per form is not possible.
Additional Information
Setting AutoFlush or AutoReload does not help.
Tags No tags attached.
Attached Files zip file icon DemoSaving.zip [^] (13,216 bytes) 2005-04-29 03:02

- Relationships

-  Notes
(0007079)
jfudickar (developer)
2005-04-28 13:58

Could you please create a small sample and add this to this bug entry.
(0007083)
dbudelsky (reporter)
2005-04-29 03:06

Hello, I added a small Demo showing the behaviour with Ini files.
Note that the Edit1.Text in Form2 is loaded from the INI file,
but stays the same every time the program is started. When you
abort the application after the writing of this parameter, the
value should change in the ini file.
The Form2 Properties are never in the file after program closure.
(0007093)
dbudelsky (reporter)
2005-05-02 02:12

Reminder sent to: jfudickar

Hello,
as you requersted, I sent an example and a short text describing
the misbehaviour. Sorry, if this is a reminder doublette.

Dietmar
(0007100)
jfudickar (developer)
2005-05-02 13:05

Sorry i can't reproduce it.

You must change AutoFlush and AutoReload in BOTH forms to TRUE.

The much better way is to work with only one AppStorage-Component, maybe based in a Datamodule. This component can be connected to all of your FormStorage Components. This is the way i use the component. With a lot of forms in one config.

Please give me a short feedback if you could manage your problem.

Greetings
Jens
(0007107)
dbudelsky (reporter)
2005-05-04 01:50

You are right, I missed someway to set the properties in all components.
The only thing which still doesn't work is the storage of "global" values in the same INIfile with TInifile. A FormStorage in the recmmended Data Module would help for that, I think.
Sorry for alarming you and thank you for the great components. The idea of
breaking up the formstorage into two components is good even though it
produces some work and questions while updating applications to JVCL 3.0.

Sorry again for every inconvenience by me.
(0007108)
jfudickar (developer)
2005-05-04 09:35

NO Problem with this.

Greetings
Jens

- Issue History
Date Modified Username Field Change
2005-04-28 09:31 dbudelsky New Issue
2005-04-28 13:58 jfudickar Note Added: 0007079
2005-04-28 13:58 jfudickar Issue Monitored: jfudickar
2005-04-28 13:58 jfudickar Status new => feedback
2005-04-29 03:02 dbudelsky File Added: DemoSaving.zip
2005-04-29 03:06 dbudelsky Note Added: 0007083
2005-05-02 02:12 dbudelsky Note Added: 0007093
2005-05-02 13:05 jfudickar Note Added: 0007100
2005-05-03 23:56 jfudickar Status feedback => assigned
2005-05-03 23:56 jfudickar Assigned To => jfudickar
2005-05-03 23:56 jfudickar Status assigned => feedback
2005-05-04 01:50 dbudelsky Note Added: 0007107
2005-05-04 09:35 jfudickar Status feedback => resolved
2005-05-04 09:35 jfudickar Resolution open => fixed
2005-05-04 09:35 jfudickar Note Added: 0007108


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker