Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002939 [JEDI VCL] 00 JVCL Components minor always 2005-05-08 09:42 2005-05-09 03:14
Reporter messenjah View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002939: jvHTLabel does not update link colors when mouse leaves
Description I have a HTLabel with 2 links. If i put the mouse on 1 link, it turns red. If i now move the mouse very quickly, off the htlabel, the link stays red, while it should turn blue
Additional Information This problem arises because no WM_MOUSEMOVE is sent to HTLabel.
I propose adding this to TJvCustomHTLabel definition:
    procedure MouseLeave(AControl: TControl); Override;

with this as implementation
procedure TJvCustomHTLabel.MouseLeave(AControl: TControl);
begin
  invalidate;
  inherited;
end;
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007119)
AHUser (developer)
2005-05-09 03:14

Fixed in CVS.

- Issue History
Date Modified Username Field Change
2005-05-08 09:42 messenjah New Issue
2005-05-09 03:14 AHUser Status new => resolved
2005-05-09 03:14 AHUser Resolution open => fixed
2005-05-09 03:14 AHUser Assigned To => AHUser
2005-05-09 03:14 AHUser Note Added: 0007119


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker