Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002947 [JEDI VCL] 03 Donations feature N/A 2005-05-11 14:12 2005-05-18 12:36
Reporter korecek View Status public  
Assigned To outchy
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002947: Conversion Of Delphi Examples Into BCB6
Description The uploaded zip files contains conversion of Delphi examples into BCB6.
Additional Information
Tags No tags attached.
Attached Files zip file icon JvShellHook.zip [^] (6,918 bytes) 2005-05-11 14:12
zip file icon JvSHFileOperation.zip [^] (7,207 bytes) 2005-05-11 14:13
zip file icon JvStarfield.zip [^] (3,759 bytes) 2005-05-11 14:13
zip file icon JvStringGrid.zip [^] (5,274 bytes) 2005-05-11 14:14
zip file icon JvSystemPopup.zip [^] (4,679 bytes) 2005-05-11 14:14
zip file icon JvSystemPopUp2.zip [^] (5,793 bytes) 2005-05-11 14:15
zip file icon JvThread.zip [^] (5,035 bytes) 2005-05-11 14:15
zip file icon JvTimeline.zip [^] (25,623 bytes) 2005-05-11 14:16
zip file icon JvTipOfDay.zip [^] (5,830 bytes) 2005-05-11 14:16
zip file icon JvTMTimeLine.zip [^] (13,764 bytes) 2005-05-11 14:17
zip file icon JvTransparentButton.zip [^] (39,067 bytes) 2005-05-11 14:18
zip file icon JvTreeViewAsMenu.zip [^] (4,762 bytes) 2005-05-11 14:18
zip file icon JvUninstallControls.zip [^] (4,757 bytes) 2005-05-11 14:19
zip file icon JvWindowsTitle.zip [^] (4,437 bytes) 2005-05-11 14:19

- Relationships

-  Notes
(0007133)
outchy (administrator)
2005-05-12 01:41

Thanks for doing this translation, I will submit your files in the CVS repository.
(0007138)
outchy (administrator)
2005-05-12 09:34

These files are now in the CVS. I modified them to be compatible with BCB5 (some functions require more parameters (non-default value), some properties in the *.dfm were not present).
It will be available for anonymous access in some hours.
(0007148)
korecek (reporter)
2005-05-13 02:45

Thanks for all modification regarding BCB5 compatibility and also for other corrections.

I have only one my short note regarding *.bpr files.
I tried to do these files according to the guidebook which I got some time
before from Olivier (OBones).
http://homepages.borland.com/jedi/issuetracker/view.php?id=2384 [^]

There is also written:
- Clean up the XML in the bpr file so that the LIBRARIES, PACKAGES and SPARELIBS nodes are empty. Once cleaned up, ensure it compiles and DO NOT save it.

At the moment, bpr files are not clened up and under BCB6 are problems
with "first attempt" compilation. ;-)

Anyhow thank you.
(0007149)
outchy (administrator)
2005-05-13 03:14

You're right, I cleaned the .xml but I saved the project just after :(
(0007150)
outchy (administrator)
2005-05-13 03:28

I fixed this bug in the CVS repository.
But I keep relative directories because they are only relative inside the JVCL directory (not the entire HDD).
(0007228)
obones (administrator)
2005-05-18 12:35

Thanks A LOT for all this.
I just tested, they all worked fine. I however have some remarks:

The ddp file is useless, you can omit it should you contribute again.
The res file, on the other hand is useful and can be shared by C6 and C5. So "outchy", please add them next time.

Oh, and because of the recent TJvTranparentButton and TJvTransparentButton2 merger, I had to update the demo a bit. But that's no biggy.
Cheers
Olivier

- Issue History
Date Modified Username Field Change
2005-05-11 14:12 korecek New Issue
2005-05-11 14:12 korecek File Added: JvShellHook.zip
2005-05-11 14:13 korecek File Added: JvSHFileOperation.zip
2005-05-11 14:13 korecek File Added: JvStarfield.zip
2005-05-11 14:14 korecek File Added: JvStringGrid.zip
2005-05-11 14:14 korecek File Added: JvSystemPopup.zip
2005-05-11 14:15 korecek File Added: JvSystemPopUp2.zip
2005-05-11 14:15 korecek File Added: JvThread.zip
2005-05-11 14:16 korecek File Added: JvTimeline.zip
2005-05-11 14:16 korecek File Added: JvTipOfDay.zip
2005-05-11 14:17 korecek File Added: JvTMTimeLine.zip
2005-05-11 14:18 korecek File Added: JvTransparentButton.zip
2005-05-11 14:18 korecek File Added: JvTreeViewAsMenu.zip
2005-05-11 14:19 korecek File Added: JvUninstallControls.zip
2005-05-11 14:19 korecek File Added: JvWindowsTitle.zip
2005-05-12 01:39 outchy Status new => assigned
2005-05-12 01:39 outchy Assigned To => outchy
2005-05-12 01:41 outchy Note Added: 0007133
2005-05-12 09:34 outchy Note Added: 0007138
2005-05-12 09:34 outchy Status assigned => acknowledged
2005-05-13 02:45 korecek Note Added: 0007148
2005-05-13 03:14 outchy Note Added: 0007149
2005-05-13 03:28 outchy Note Added: 0007150
2005-05-18 12:35 obones Status acknowledged => resolved
2005-05-18 12:35 obones Resolution open => fixed
2005-05-18 12:35 obones Note Added: 0007228


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker