Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002970 [JEDI VCL] 00 JVCL Components minor always 2005-05-19 18:37 2006-04-05 01:20
Reporter rwatson View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0002970: JvNTEventLog hangs if OnChange is assigned
Description If you use the JvNTEventLog with the OnChange event assigned, your application will hang when the component is destroyed. This is caused by the call WaitForSingleObject where the event handle is not being signaled on destruction.
Additional Information Recommended changes. Create a destructor TNotifyChangeEventLog destructor that will call SetEvent(FEventHandle) and alter the DoChange (or Execute) so that the event handler is NOT called when the thread is Terminated is true.
Tags No tags attached.
Attached Files

- Relationships
related to 0002889resolvedobones Access Violation with JvNTEventLog 

-  Notes
(0007256)
obones (administrator)
2005-05-20 02:41

I've assigned the OnChange event (no code inside it) to the JVNTEventLog object from the demo provided with JVCL 3.00 and the application is closing down just fine.
Could you try it yourself?
Could you also post a sample application that reproduces the bug?
(0007277)
anonymous (viewer)
2005-05-20 07:41

May be something on my end. I received "Access violation at address 7800AE32 in module 'RPCRT4.dll'. Read of address 008E8000." When trying to run the EventViewer demo.
(0007278)
obones (administrator)
2005-05-20 08:03

The AV is in 0002889 and I can't do anything about that, the API function behaves very weirdly.
(0008788)
obones (administrator)
2006-03-31 05:55

Code has been reviewed and reworked a bit to avoid locking up infinitely.
This will be in CVS as soon as the server is back.
(0008934)
obones (administrator)
2006-04-05 01:20

This is now in CVS

- Issue History
Date Modified Username Field Change
2005-05-19 18:37 rwatson New Issue
2005-05-20 02:41 obones Note Added: 0007256
2005-05-20 02:41 obones Status new => feedback
2005-05-20 07:41 anonymous Note Added: 0007277
2005-05-20 08:02 obones Relationship added duplicate of 0002889
2005-05-20 08:02 obones Relationship deleted 0002889
2005-05-20 08:03 obones Relationship added related to 0002889
2005-05-20 08:03 obones Note Added: 0007278
2006-03-31 05:55 obones Note Added: 0008788
2006-03-31 05:55 obones Status feedback => confirmed
2006-04-05 01:20 obones Status confirmed => resolved
2006-04-05 01:20 obones Resolution open => fixed
2006-04-05 01:20 obones Assigned To => obones
2006-04-05 01:20 obones Note Added: 0008934


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker