Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002988 [JEDI VCL] 00 JVCL Components crash always 2005-05-24 08:51 2005-08-28 09:37
Reporter andik View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00 RC 1
Summary 0002988: Installation Bugs in Delphi6PE
Description I tried to install JVCL in Delphi6 there where MUCH Problems:
-Installer threw Just errors while Compiling
-Manuel compiling: BUGS
 -Much Units p.e. jvInterpreter use unit DB. But DB isn't supported in D6PE
 -jvInterpreter also uses BDE, also not suported

 -jvXPBar line 118. " dxColor_FocusedFrameColorXP = clHotLight;" clHotlight not
  found
 -jvParameterlist line 847: " on E: EVariantTypeCastError do"
  -> EVariantTypeCastError not found - fixed with EVariantError
 -jvComputerInfoEx:
   "property ColorMenuHighlight: TColor index COLOR_MENUHILIGHT read GetColor write SetColor stored False;
    property ColorMenuBar: TColor index COLOR_MENUBAR read GetColor write SetColor stored False;"
  -> COLOR_MENUHIGHLIGHT and COLOR_MENUBAR not found . i don't the hell know why. because they are declared in the same file??? Replaced with 29 and 30. works
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007339)
obones (administrator)
2005-05-24 09:14

Are you sure you activated the DelphiPersonal $DEFINE in the include file?
(0007340)
AHUser (developer)
2005-05-24 13:23
edited on: 2005-05-24 13:34

That is something the installer should do itself because it hides this DEFINE in the option dialog.

What does the Installer say while trying to compile the packages about the used Delphi version? Does it say "Delphi 6 Personal Editon" or something else on the compile progress screen?

(0007349)
anonymous (viewer)
2005-05-25 15:43

The funny thing is, that this Installer showed "Dephi 6 (STD)" not Personal. And it additionaly hided that define.
My Delphi Version is 6.0 PE (Build 6.240) Update 2.
But an english Delphi with an german update. (I think)
Also I use gexperts, but I don't think this is important.

While manual compiling I didn't set any defines. (sometimes I'm silly).
But I used the D6PER .bpl
And addtional, these "use DB" Bugs where Not in {$IFDEF}/{ENDIF}
(0007350)
andik (reporter)
2005-05-25 15:44

sorry, the anonymous note was my note. First I need to learn sth. about this system...
(0007353)
obones (administrator)
2005-05-26 05:32

That's normal if they are not ifdefed, the files are not even part of the packages, should you define $DELPHI_PERSONNAL and regenerate the packages, which is what the installer does.
Further to this, the bpg file includes the packages in d6per, specifically crafted to not include any DB related stuff.
But first, sort out your upgrades, a German one on an English Delphi is a recipe for disaster.
(0007379)
anonymous (viewer)
2005-06-01 19:18

I have also encountred with same problems and same workarounds helped.
also have delphi 6
(0007873)
obones (administrator)
2005-08-28 09:37

I'm considering this fixed with the latest sources.
Please open a new issue if it's not the case.

- Issue History
Date Modified Username Field Change
2005-05-24 08:51 andik New Issue
2005-05-24 09:14 obones Note Added: 0007339
2005-05-24 09:14 obones Status new => feedback
2005-05-24 13:23 AHUser Note Added: 0007340
2005-05-24 13:34 AHUser Note Edited: 0007340
2005-05-25 15:43 anonymous Note Added: 0007349
2005-05-25 15:44 andik Note Added: 0007350
2005-05-26 05:32 obones Note Added: 0007353
2005-06-01 19:18 anonymous Note Added: 0007379
2005-08-28 09:37 obones Status feedback => resolved
2005-08-28 09:37 obones Resolution open => fixed
2005-08-28 09:37 obones Assigned To => obones
2005-08-28 09:37 obones Note Added: 0007873


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker