Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002995 [JEDI VCL] 00 JVCL Components minor always 2005-05-26 06:03 2005-05-26 07:50
Reporter anonymous View Status public  
Assigned To
Priority normal Resolution open  
Status closed   Product Version 3.00
Summary 0002995: jvAppStorage XML produces invalid XML
Description Hi there,

I've been trying to figure out how to use the jvAppStorage system, and got as far as storing form data in an XML file. However, the resulting XML file is not well-formed:

<?xml version="1.0" encoding="iso-8859-1"?>
<Configuration>
  <frmMain>
    <FormVersion>0</FormVersion>
    <ShowCmd>1</ShowCmd>
    <Flags>0</Flags>
    <PixelsPerInch>96</PixelsPerInch>
    <MinMaxPos(1280x1024)>-1,-1,-1,-1</MinMaxPos(1280x1024)>
    <MinMaxPos>-1,-1,-1,-1</MinMaxPos>
    <NormPos(1280x1024)>365,316,1094,900</NormPos(1280x1024)>
    <NormPos>365,316,1094,900</NormPos>
  </frmMain>
</Configuration>

Specifically, parentheses are not permitted in tag names, so this bit is wrong:

<MinMaxPos(1280x1024)>

It shouldn't be hard to fix this, by changing it to (for example)

<MinMaxPos-1280x1024>
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0002750resolvedjfudickar FormStorage XML is not valid. 

-  Notes
(0007355)
obones (administrator)
2005-05-26 07:50

See 0002750

- Issue History
Date Modified Username Field Change
2005-05-26 06:03 anonymous New Issue
2005-05-26 07:50 obones Relationship added child of 0002750
2005-05-26 07:50 obones Relationship replaced duplicate of 0002750
2005-05-26 07:50 obones Status new => closed
2005-05-26 07:50 obones Note Added: 0007355


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker