Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002999 [JEDI VCL] 00 JVCL Components minor always 2005-05-27 05:49 2005-05-27 07:59
Reporter borzov View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version
Summary 0002999: Bad drawing of the TjvSpeedButton when XP themes are enabled (after fixing 0002918)
Description When the XP theme is applied, I have the folowing strange behaviour of the TJvSpeedButton - when the mouse enters that control, the latter is highlighted, what is correct, but when the mouse leaves the control, the highlighting remains. That all happens when Transparent = false, with Transparent = true everything is correct. But before recent changes in CSV everything worked correct regardless of Transparent value.
Additional Information
Tags No tags attached.
Attached Files gif file icon Untitled-1.gif [^] (2,810 bytes) 2005-05-27 05:49

- Relationships
child of 0002918resolvedAHUser Bad drawing of the TjvSpeedButton when XP themes are enabled 

-  Notes
(0007363)
AHUser (developer)
2005-05-27 07:59

The issue is now fixed without the BitBlt call. The actual problem is that the PerformEraseBackground function painted the background at the wrong position when it was used on the MemDC from the WM_PAINT handler. This is now fixed.

- Issue History
Date Modified Username Field Change
2005-05-27 05:49 borzov New Issue
2005-05-27 05:49 borzov File Added: Untitled-1.gif
2005-05-27 05:51 borzov Issue Monitored: borzov
2005-05-27 06:28 obones Relationship added child of 0002918
2005-05-27 07:59 AHUser Status new => resolved
2005-05-27 07:59 AHUser Resolution open => fixed
2005-05-27 07:59 AHUser Assigned To => AHUser
2005-05-27 07:59 AHUser Note Added: 0007363


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker