Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003002 [JEDI VCL] 00 JVCL Components major always 2005-05-28 10:25 2005-06-12 12:17
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003002: TJvHTLabel transparancy issue
Description When a TJvHTLabel is placed on a theme enabled form with transparent set to true, it looks perfect unless you move your mouse over it. Then a white color (not the color of the label itself) is placed in the background. As a workaround for this, I set OnMouseMove to contain the following line,

TJvHTLabel(Sender).Canvas.Brush.Style:=bsClear;

This fixed the issue. However, if you then click on the label (no click code or anything) the same problem appears until the labels caption is updated. Using the same trick above but for OnClick works as well. Just seems like someone missed something when checking/setting the style when drawing.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0002898resolvedobones TJvHTLabel goes on white background after onmousemove 

-  Notes
(0007364)
obones (administrator)
2005-05-28 17:16

Duplicate of 002898
(0007365)
anonymous (viewer)
2005-05-29 01:09

I just downloaded the nightly zip file and installed it. This exact bug appears to still exist. Perhaps I've missed something, but I've gone so far as to make Delphi compile all the units included in my projects directly, including JvJVCLUtils (which is version 1.166 now) and it all looks good to me. But it still has the exact same problem as before?
(0007373)
obones (administrator)
2005-06-01 05:44

Well then, please create a sample application and zip its sources, then attach it here.
But when you update from CVS (or the daily zips), you must recompile the packages as well.
(0007393)
anonymous (viewer)
2005-06-02 16:12

Ok, this will be a little odd to explain. I don't need a project though, as I would still have to explain exactly how this happens. After looking into this further, I've found there to be a strange behaviour of the transparent property. When you first drop a TJvHTLabel on the form, Transparent is set to true. If you change it to false (Delphi 2005 at least) it gets bold. This indicates it is not the default value. However, with TJvHTLabel if you change it back to true again, it stays bold. When it is the default true it behaves exactly as you'd want. When it is the non-default true it produces the result I've described (and that you've seen in the past). This appears to be the same in TLabel which TJvHTLabel descends from (property wise).

I hope this allows you to reproduce the problem. Basically, drop a TJvHTLabel, set transparent to false, set it back to true, run the application. Move the mouse over the label, it will get a white background.
(0007414)
anonymous (viewer)
2005-06-10 15:16

I can confirm this.
(0007437)
obones (administrator)
2005-06-12 07:34

A few remarks:

1. Get a login on Mantis, it is much preferable for us to speak to someone rather than to "anonymous".
2. If I ask for a demo, it's because I don't have much time and want to make the most of it by looking at the bug.
3. The default value for Transparent is False, in Delphi 6 at least
4. All said, I can see the bug, I'm investigating.
(0007442)
obones (administrator)
2005-06-12 12:17

This was a duplicate of 0002898, it's just that some changes made later forgot about the fix put in place for 0002898.
Anyway, this is now back in and fixed again.

- Issue History
Date Modified Username Field Change
2005-05-28 10:25 anonymous New Issue
2005-05-28 17:15 obones Relationship added duplicate of 0002898
2005-05-28 17:16 obones Status new => closed
2005-05-28 17:16 obones Note Added: 0007364
2005-05-29 01:09 anonymous Status closed => feedback
2005-05-29 01:09 anonymous Resolution open => reopened
2005-05-29 01:09 anonymous Note Added: 0007365
2005-06-01 05:44 obones Note Added: 0007373
2005-06-02 16:12 anonymous Note Added: 0007393
2005-06-10 15:16 anonymous Note Added: 0007414
2005-06-12 07:34 obones Note Added: 0007437
2005-06-12 12:17 obones Status feedback => resolved
2005-06-12 12:17 obones Resolution reopened => fixed
2005-06-12 12:17 obones Assigned To => obones
2005-06-12 12:17 obones Note Added: 0007442


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker