Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003014 [JEDI VCL] 00 JVCL Components major always 2005-06-02 12:54 2005-06-02 14:47
Reporter anonymous View Status public  
Assigned To remkobonte
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003014: JvRichEdit; right-click-menu problems
Description I found two problems with the JvRichEdit component, both related to the popup menu, and probably, also to eachother;


1) Put a JvRichEdit on a form, and assign a popup menu to it. Turn of the "Allow Objects" property. Now, during runtime, when you right-click and the menu pops out, when you click on it (the menu), it will pop up again, instead of just vanish.


2) Trying to make a seperate right-click for the urls, when "AutoURLDetect" is enabled. Thought that you could use the OnURLClick-event and check for the right mouse button, but the default menu pops out first, and then, when it is closed, the "special" one.
Maybe not a bug, but surely a logic problem. Even tried to skip the built-in right menu function, and made an OnMouseDown-evend and popped the menu manually, but it was still trigged before the OnURLClick.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007392)
remkobonte (developer)
2005-06-02 14:47

(1) Is fixed in Rev 1.72.
(2) Is indeed related to (1), now the url menu pops up /before/ the default menu. You could use an OnContextPopup handler to prevent the popup of the default menu, for example:

var
  SkipNextPopup: Boolean;

procedure TForm1.JvRichEdit1URLClick(Sender: TObject;
  const URLText: String; Button: TMouseButton);
begin
  if Button = mbRight then
  begin
    SkipNextPopup := True;
    // stuff
  end;
end;

procedure TForm1.JvRichEdit1ContextPopup(Sender: TObject; MousePos: TPoint;
  var Handled: Boolean);
begin
  Handled := SkipNextPopup;
  SkipNextPopup := False;
end;

- Issue History
Date Modified Username Field Change
2005-06-02 12:54 anonymous New Issue
2005-06-02 14:47 remkobonte Status new => resolved
2005-06-02 14:47 remkobonte Resolution open => fixed
2005-06-02 14:47 remkobonte Assigned To => remkobonte
2005-06-02 14:47 remkobonte Note Added: 0007392


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker