Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003036 [JEDI VCL] 00 JVCL Components crash sometimes 2005-06-13 09:40 2006-12-18 05:31
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status closed   Product Version 2.10
Summary 0003036: Divizion by zero on PIV 3Mhz Processor
Description May be you have tested your code on slower computers, so I have a devizion by zero exception in line
Freq := Round(Cycles / Ticks);
of the procedure GetCPUSpeed because of Ticks=0 in module JclSysInfo

...
   Cycles := Stamp1 - Stamp0;
      Ticks := T1.LowPart - T0.LowPart;
      Ticks := Ticks * 100000;
      Ticks := Round(Ticks / (CountFreq.LowPart / 10));
      TotalTicks := TotalTicks + Ticks;
      TotalCycles := TotalCycles + Cycles;
      Freq := Round(Cycles / Ticks);
      Total := Freq + Freq2 + Freq3;
    end;
...
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007448)
obones (administrator)
2005-06-13 14:28

Please upgrade to the latest version of the JCL and JVCL, this has been fixed for over two years now.

- Issue History
Date Modified Username Field Change
2005-06-13 09:40 anonymous New Issue
2005-06-13 14:28 obones Status new => resolved
2005-06-13 14:28 obones Resolution open => fixed
2005-06-13 14:28 obones Assigned To => obones
2005-06-13 14:28 obones Note Added: 0007448
2006-12-14 16:05 anonymous Status resolved => feedback
2006-12-14 16:05 anonymous Resolution fixed => reopened
2006-12-18 05:31 obones Status feedback => closed
2006-12-18 05:31 obones Resolution reopened => fixed


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker