Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003056 [JEDI VCL] 00 JVCL Components crash always 2005-06-28 03:35 2005-06-29 12:27
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003056: Problem with JvDBDatePickerEdit
Description When set DateFormat to dd/MM/yyyy then on click to button to show Calendar then Calendar show correct, now click on day, Calendar hide and selected date is not select and in edit is date 30.12.1899. Wat is problem ?

If use default DateFormat d/M/yyyy then all is correct.
 
Additional Information Use JVCL from JVCL300CompleteJCL195-Build1848.zip and new version of JvDatePickerEdit from CVS at 25.6.2005.
Tags No tags attached.
Attached Files zip file icon test.zip [^] (18,976 bytes) 2005-06-29 08:27

- Relationships

-  Notes
(0007504)
obones (administrator)
2005-06-28 14:00

I cannot reproduce this. Please create a sample application, zip up its sources and attach them to this issue.
(0007507)
anonymous (viewer)
2005-06-29 07:56

Pleas see video. I use Windows XP SP2 Czech edition,
and Delphi 6 EN with Update pack 2.
(0007508)
vasa (reporter)
2005-06-29 08:15

Video is on adress http://www.alveo.cz/video/video.zip [^]
(0007509)
obones (administrator)
2005-06-29 11:42

I see this now, but it will take time to debug
(0007510)
obones (administrator)
2005-06-29 12:27

Thanks, I've now solved it.
Grab version 1.63 from the CVS of JvDatePickerEdit.pas and you'll be sorted.

- Issue History
Date Modified Username Field Change
2005-06-28 03:35 anonymous New Issue
2005-06-28 14:00 obones Note Added: 0007504
2005-06-28 14:00 obones Status new => feedback
2005-06-29 07:56 anonymous Note Added: 0007507
2005-06-29 08:07 vasa Issue Monitored: vasa
2005-06-29 08:15 vasa Note Added: 0007508
2005-06-29 08:27 vasa File Added: test.zip
2005-06-29 11:42 obones Note Added: 0007509
2005-06-29 11:42 obones Status feedback => confirmed
2005-06-29 12:27 obones Status confirmed => resolved
2005-06-29 12:27 obones Resolution open => fixed
2005-06-29 12:27 obones Assigned To => obones
2005-06-29 12:27 obones Note Added: 0007510
2005-07-08 05:15 vasa Issue End Monitor: vasa


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker