Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003070 [JEDI VCL] 00 JVCL Components major always 2005-07-03 02:18 2005-07-03 04:38
Reporter anonymous View Status public  
Assigned To AHUser
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003070: Install failed due to "xmlrtl not found" - D2005 PE JVCL300CompleteJCL195-Build1848.zip
Description Unable to install vcl as error E2202 Required package 'xmlrtl' not found.
Additional Information
Tags No tags attached.
Attached Files txt file icon InstallationLog.txt [^] (2,109 bytes) 2005-07-03 02:18

- Relationships

-  Notes
(0007521)
AHUser (developer)
2005-07-03 04:36

Delphi 2005 PE is not able to compile design time packages which require the package designide because designide requires itself xmlrtl. And Borland does not ship the file xmlrtl.dcp which is required for compiling packages that link against designide.
It is not allowed to distribute xmlrtl.dcp (xmlrtl.bpl is not enough to compile packages). But you can download a faked xmlrtl.dcp that does not have the functionality of the original (exactly: it has no functionality at all) but this is enough for the compiler.
As the released JVCL 3 has no Delphi 2005 PE (it was released before Delphi 2005PE) you must apply a patch to the JVCL 3 which also contains the faked xmlrtl.dcp.

http://jvcl.sourceforge.net/files/JVCLd9pPatch.zip [^]

- Issue History
Date Modified Username Field Change
2005-07-03 02:18 anonymous New Issue
2005-07-03 02:18 anonymous File Added: InstallationLog.txt
2005-07-03 04:36 AHUser Note Added: 0007521
2005-07-03 04:38 AHUser Status new => resolved
2005-07-03 04:38 AHUser Resolution open => fixed
2005-07-03 04:38 AHUser Assigned To => AHUser


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker