Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003076 [JEDI VCL] 02 Installation major always 2005-07-05 04:44 2006-01-05 08:11
Reporter AlanC View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003076: C++ Builder Installation fails.
Description The C++ Builder Installation terminates prematurely (compile error).

- Configuration
   o Win XP SP2
   o BCB 6 Professional Upd4
   o Delphi 7 Enterprise Upd1
   o JVCL300CompleteJCL195-Build1848.7z

- Other Info
   o JCL was installed with no errors.
     . JCL Path: C:\VCL\Components\Jedi\jcl\
     . JCL .bpl & .bpi path: C:\PROGRA~1\Borland\CBUILD~1\Projects\Bpl
     . The path above is included in the Environment Path.
   o Delphi Install works fine.

Help would be appreciated. Thanks.
Additional Information Log Capture.

"C:\Program Files\Borland\CBuilder6\Bin\make.exe" -f Makefile.mak Templates
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
[Generating: Templates]
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
Writing: ..\C6\dcc32.cfg
[Generating: Packages]
Generating packages for C6
    Loaded template.bpk
    Loaded template.cpp
    Loaded template.res
"C:\Program Files\Borland\CBuilder6\Bin\make.exe" -f makefile.mak -n
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
"C:\Program Files\Borland\CBuilder6\Bin\make.exe" -f Makefile.mak CompilePackages
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
[Compiling: Packages]
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
"C:\Program Files\Borland\CBuilder6\Bin\make.exe" -f Makefile.mak CompilePackages
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
[Compiling: Packages]
    "C:\Program Files\Borland\CBuilder6\bin\make.exe" -l+ -f "C6 Packages.mak"
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
[Compiling: JvCoreC6R.bpl]
    "C:\Program Files\Borland\CBuilder6\bin\bpr2mak" -t..\BCB.bmk JvCoreC6R.bpk
Loading project file
Loading template
Generating Makefile
.........................................
    "C:\Program Files\Borland\CBuilder6\bin\make" -f JvCoreC6R.mak
MAKE Version 5.2 Copyright (c) 1987, 2000 Borland
    "C:\PROGRA~1\Borland\CBUILD~1\bin\..\BIN\ilink32" @MAKE0000.@@@
Turbo Incremental Link 5.66 Copyright (c) 1997-2002 Borland
Fatal: Unable to open file 'CJCL.BPI'

** error 2 ** deleting JvCoreC6R.bpl

** error 1 ** deleting "C:\Program Files\Borland\CBuilder6\Projects\Bpl"\JvCoreC6R.bpl

** error 1 ** deleting CompilePackages
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007527)
obones (administrator)
2005-07-05 12:59

Locate where CJCL.bpi is on your machine.
Ensure this directory is in the PATH environment variable.
Retry.
(0007557)
AlanC (reporter)
2005-07-13 06:04

My CJCL.BPI is located in
"c:\Program Files\Borland\CBuilder6\Projects\Bpl\CJCL.BPI"

The PATH environment variable was correct but I checked it by running an application in that folder from the Command Prompt c:\ and it's fine !

I'm using the new linker from Borland but the result is the same as the old one ! In desperation I even made the CJCL.BPI file uppercase (dont laugh I've had case sensitivity issues before)!

Should I install manually (I'd rather use the great JVCL installer).

Thanks Alan.
(0007560)
obones (administrator)
2005-07-14 08:07

That is very weird. Have you run C++ Builder at least once before installing the JCL/JVCL? I'm asking because it creates registry keys that may needed by the installer. Apart from that, I can't see anything else.
(0008029)
laserflor (reporter)
2005-10-14 10:34

I had the same problem today:

The output path "C:\Program Files\Borland\CBuilder6\Projects\Bpl\CJCL.BPI" wouldn't work. I tried similar.

The created makefile (c6 package.mak) which is created by the JediInstaller doesn't realise the changes of the output path for libraries.

The standard output path is "C:\Program Files\Borland\CBuilder6\Projects\Lib".
It seems to be nothing read from the registry by the installer.

Can I access to a changed JediInstaller over CVS?

Greetings Rolf
(0008128)
obones (administrator)
2005-11-22 09:07

Use http://jcl.sf.net/daily/ [^] and http://jvcl.sf.net/daily/ [^] to get the latest versions.
(0008292)
obones (administrator)
2006-01-05 08:11

No answers in more than 14 days, this is believed to be fixed

- Issue History
Date Modified Username Field Change
2005-07-05 04:44 AlanC New Issue
2005-07-05 12:59 obones Note Added: 0007527
2005-07-13 06:04 AlanC Note Added: 0007557
2005-07-14 08:07 obones Note Added: 0007560
2005-07-14 08:07 obones Status new => feedback
2005-10-14 10:34 laserflor Note Added: 0008029
2005-11-22 09:07 obones Note Added: 0008128
2006-01-05 08:11 obones Status feedback => resolved
2006-01-05 08:11 obones Resolution open => fixed
2006-01-05 08:11 obones Assigned To => obones
2006-01-05 08:11 obones Note Added: 0008292


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker