Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003128 [JEDI VCL] 00 JVCL Components minor always 2005-08-03 11:08 2006-06-08 02:21
Reporter anonymous View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003128: JvCustomImageButton shows focus rect in Win XP
Description In Windows XP, buttons don't show focus rects. However, JvFooterBtn shows them. This is an descendant of TJvCustomImageButton and that component draws a focus rect, which is *incorrect* in Windows XP style.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007660)
anonymous (viewer)
2005-08-03 14:09

The description is not correct. In Windows XP, buttons DO show focus rects, but *only* when the button really HAS the focus.

But the TjvCustomImageButton (and, so, TJvFooterBtn) also show a focus rect when the button has the 'Default' property set. In Windows XP style, however, a button should not show a focus rect when it is the default button, but does not have the focus.
(0008801)
obones (administrator)
2006-03-31 06:59

I can't reproduce this with the latest version. Please try with it (3.20 or even better, CVS) and let us know.
(0009425)
obones (administrator)
2006-06-08 02:20

No news, assuming this is fixed in the latest daily:

http://jvcl.sf.net/daily/ [^]

- Issue History
Date Modified Username Field Change
2005-08-03 11:08 anonymous New Issue
2005-08-03 14:09 anonymous Note Added: 0007660
2005-08-05 01:45 pgwillemsen Issue Monitored: pgwillemsen
2006-03-31 06:59 obones Note Added: 0008801
2006-03-31 06:59 obones Status new => feedback
2006-06-08 02:20 obones Status feedback => resolved
2006-06-08 02:20 obones Resolution open => fixed
2006-06-08 02:20 obones Assigned To => obones
2006-06-08 02:20 obones Note Added: 0009425


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker