Project JEDI - Issue Tracker
Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003131 [JEDI VCL] 00 JVCL Components major always 2005-08-05 01:51 2005-11-22 09:11
Reporter pgwillemsen View Status public  
Assigned To obones
Priority normal Resolution fixed  
Status resolved   Product Version 3.00
Summary 0003131: TJvDBGrid handles OnKeyPress event twice
Description A TJvDBGrid handles an OnKeyPress() event twice. One time correctly, one time with var Key equal to #0. This problem occurs after updating to version 3.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0007812)
edbored (reporter)
2005-08-18 22:25

Could not reproduce with D7E/W2K using updated jcl/jvcl from cvs 2005/08/17.

Tested with simple "Showmessage(Key)" in event handler - only the actual key pressed is displayed.

Does this occur in a simple test case?

EdB
(0008010)
Informatix (developer)
2005-10-10 09:16

I tried to reduce the number of KeyPressed event triggers as much as it was possible. I can't do better. In most cases, you'll have only one KeyPressed event fired.
Verify that your JVCL files are up-to-date.

Fred
(0008133)
obones (administrator)
2005-11-22 09:11

No answers for more than 14 days, this is considered fixed. Use the daily snapshots from here:

http://jvcl.sf.net/daily/ [^]

- Issue History
Date Modified Username Field Change
2005-08-05 01:51 pgwillemsen New Issue
2005-08-18 22:25 edbored Note Added: 0007812
2005-10-10 09:16 Informatix Note Added: 0008010
2005-11-22 09:11 obones Status new => resolved
2005-11-22 09:11 obones Resolution open => fixed
2005-11-22 09:11 obones Assigned To => obones
2005-11-22 09:11 obones Note Added: 0008133


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker